A.8 Linux/Solaris Inventory and Monitoring Commands

This section contains lists of commands used by PlateSpin Recon during inventory and monitoring.

A.8.1 Inventorying Solaris

Table A-7 Inventorying Commands

Command

Description

kstat
#Get network connection speed. 
chmod
#Change file access permissions for the inventory script that is placed on the machine being inventoried.
rm
#Remove the inventory script that was placed on the machine.
prtdiag
#Get CPU cache information and machine model for Sparc. 
psrinfo
#Get processor information such as family, model, step, etc., which are related to x86 mainly. 
isainfo
#Get CPU instruction set information such as sse, sse2, mmx, etc., which are related to x86 mainly. 
prtconf 
#Get configured device information, which is related to L2 cache information of x86, network adapter resolving, and ACPI support.
ifconfig 
#Get network related information such as IP address, DHCP, net mask, etc.
ndd 
#Get network connection speed.
uname 
#Determine kernel version.
mount 
#Get boot loader.
pkginfo 
#Get installed programs.
ps 
#Get process information.
who 
#Get run level.
hostname
#Get host name.

A.8.2 Inventorying LINUX

Table A-8 Inventorying Commands

Command

Description

chkconfig 
#Get service(daemon) information.
df 
#Get volume information.
mount
#Get volume information.
e2label 
#Get disk label.
route 
#Get gateway.
ifconfig 
#Get network related information such as IP address, net address, and so on.
egrep 
#Get DHCP information.
getcfg (SUSE*) 
#Get DHCP for SUSE.
rpm 
#Get installed programs.
lspci 
#Get PCI device information such as vendor name, device model in human readable format.
iwconfig 
#Get wireless network adapter NIC list.
iwlist 
#Get wireless bit rate.
ethtool 
#Get speed and link status for network connection.
dmesg 
#Get real MAC address.
kudzu (Redhat*) 
#Get network device information for Redhat Linux.
hwinfo (SUSE) 
#Get network adapter information for SUSE Linux.
fdisk 
#Determine if a partition is active or not.
runlevel 
#Get current run level.
hostname
#Get host name and DNS domain name.

A.8.3 Monitoring

Table A-9 Monitoring Commands

Command

Description

psrinfo (SunOS*) 
#count processor number.
mpstat  (SunOS)
#Get processor time per cpu instance.
vmstat (SunOS)
#Get processor queue length and memory available.
ifconfig  
#Get NIC list.
sed  
#Edit input stream.
tail  
#Edit input stream.
netstat (SunOS) 
#Get network package transfer rate.
kstat (SunOS)
#Get NIC speed.
prtconf (SunOS)
#Get module and instance binding for NIC.
iostat (SunOS)
#Get disk io information such as queue and speed.
expr 
#evaluate express.

A.8.4 Text Processing

grep, cat, cut, awk, ls