6.1 Designer 中的过滤器任务

本节包含有关在 Designer 中执行与过滤器相关的常见任务的说明:

6.1.1 访问过滤器编辑器

过滤器编辑器允许您编辑过滤器。可以通过三种方法访问过滤器编辑器:通过模型大纲、策略流和策略集视图。

模型大纲视图

  1. 在打开的项目中,单击“大纲”选项卡。

  2. 单击“显示模型大纲”图标。 定义 XSLT 策略的策略构建器界面。

  3. 选择要用于管理过滤器的驱动程序,然后单击右侧的加号。

  4. 双击“过滤器”图标以起动过滤器编辑器。

    或者

    右击并选择“编辑”。

策略流程视图

  1. 在打开的项目中,单击“大纲”选项卡。

  2. 选择“显示策略流”图标。

  3. 双击“同步”图标或“通知”图标以起动过滤器编辑器。

  4. 当过滤器出现在“策略流”下面的“策略集管理器”中时,双击该过滤器以起动过滤器编辑器。

    或者

    右击并选择“编辑策略”>“过滤器”。

策略集视图

  1. 双击此过滤器策略。

键盘支持

Table 6-1 过滤器编辑器键盘支持功能

操作

说明

向上箭头

在过滤器编辑器中上移光标。

向下箭头

在过滤器编辑器中下移光标。

向左箭头

折叠显示的信息

向右箭头

展开显示的信息。

Insert

添加类。

Ctrl+Insert

添加特性。

Delete

删除选定的项目。

Enter

访问编辑方式。再次按 Enter 可提交更改。

Esc

退出编辑方式。

6.1.2 编辑过滤器

过滤器编辑器允许您创建并编辑过滤器。要显示上下文菜单,请右击某项目。

Figure 6-1 过滤器选项

去除或添加类和特性

通过去除或添加类和特性,确定在已连接数据存储区和 Identity Vault 之间同步的对象。

去除类或特性

如果不想同步类或特性,最好从过滤器中彻底地去除类或特性。可以使用两种方法从过滤器中添加或去除特性和类:

  • 右击想要去除的类或特性,然后选择“删除”。
  • 选择想要去除的类或特性,然后单击右上角的“删除”图标 。
添加类
  1. 右击过滤器编辑器,然后单击“添加类”。

    或者

    单击右上角的“添加类”图标

  2. 浏览并选择想要添加的类,然后单击“确定”。

  3. 更改选项以同步信息。

  4. 要保存这些更改,请单击“文件”>“保存”。

添加特性
  1. 在过滤器编辑器中右击,然后单击“添加特性”。

    或者

    单击右上角的“特性”图标 。

  2. 浏览并选择要添加的特性,然后单击“确定”。

  3. 更改选项以同步信息。

  4. 要保存这些更改,请单击“文件”>“保存”。

修改多个特性

过滤器编辑器允许您同时修改多个特性。按住 Ctrl 键并选择多个特性;更改选项时将更改所有选定特性的选项。

复制现有的过滤器

您可以从其它驱动程序中复制一个现有的过滤器,然后在当前使用的驱动程序中使用该过滤器。

  1. 单击“复制现有过滤器”图标

    或者

    在过滤器编辑器中右击,然后单击“复制现有过滤器”。

  2. 浏览至要复制的过滤器对象并选择该对象,然后单击“确定”。

    如果项目中有多个 Identity Vault,则可以从其它 Identity Vault 中复制过滤器。如果正在浏览至其它对象并选择了其它对象,则可以浏览至其它 Identity Vault 并使用其储存的过滤器。

设置特性的默认值

将新特性添加到过滤器时,可以定义新特性的默认值。

  1. 单击右上角的“设置新特性的默认值”图标 。

  2. 选择希望新特性具有的选项,然后单击“确定”。

更改过滤器设置

过滤器编辑器提供了更改选项,以更改 Identity Vault 和已连接系统之间同步信息的方式。过滤器具有针对类和特性的不同设置。

  1. 在过滤器编辑器中选择一个类。

  2. 更改所选类的过滤器设置。

    选项

    定义

    发布者

    • 同步: 允许将该类从已连接系统同步到 Identity Vault。

    • 忽略: 不将该类从已连接系统同步到 Identity Vault。

    订购者

    • 同步: 允许将该类从 Identity Vault 同步到已连接系统。

    • 忽略: 不将该类从 Identity Vault 同步到已连接系统。

    创建用户主目录

    • 是: 自动创建用户主目录。

    • 否: 不创建用户主目录。

    跟踪模板成员

    • 是: 确定发布者通道从模板创建对象时是否保持 Member of Template(模板成员)特性。

    • 否: 不跟踪 Member of Template(模板成员)特性。

  3. 选择特性。

  4. 更改选定特性的过滤器设置。

    选项

    定义

    发布者

    • 同步: 报告并自动同步对该对象的更改。

    • 忽略: 既不报告也不自动同步对该对象的更改。

    • 通知: 报告但不自动同步对该对象的更改。

    • 重设置: 将对象值重设置为由相反通道指定的值。(可以在发布者通道或订购者通道设置该值,但不可以在两个通道均设置该值。)

    订购者

    • 同步: 报告并自动同步对该对象的更改。

    • 忽略: 既不报告也不自动同步对该对象的更改。

    • 通知: 报告但不自动同步对该对象的更改。

    • 重设置: 将对象值重设置为由相反通道指定的值。(可以在发布者通道或订购者通道设置该值,但不可以在两个通道均设置该值。)

    合并权限

    • 默认行为: 如果未在任一通道中同步某特性,则不发生合并。

      如果在一个通道(而未在另一个通道)中同步某特性,则去除该通道目标的所有现有值,并由该通道源的值代替。如果源具有多个值而目标只能容纳一个值,则目标侧仅使用其中的一个值。

      如果在两个通道中均同步某特性,且两侧都只能容纳一个值,则只要 Identity Vault 存在值,已连接应用程序便可获得 Identity Vault 值。在这种情况下,Identity Vault 从已连接应用程序获得值(如果有)。

      如果在两个通道中均同步某特性,且只有一侧能容纳多个值,则如果单值侧的值不在多值侧,此值将被添加到多值侧。如果单值侧没有值,则可以选择值添加到单值侧。

      这始终是有效的行为。

    • Identity Vault: 如果某特性在订购者通道中同步而未在发布者通道中同步,则 Identity Vault 的行为方式与默认行为相同。

      在订购者通道中同步时,这是有效的行为。

    • 应用程序: 如果某特性在发布者通道中同步而未在订购者通道中同步,则应用程序的行为方式与默认行为相同。

      在发布者通道中同步时,这是有效的行为。

    • 无:无论同步与否,都不发生合并。

    对 Identity Manager 的优化修改

    • 是: 在发布者通道中检查对该特性的更改,以确定在 Identity Vault 中所做的最少更改。

    • 否: 不检查更改。

  5. 单击“保存”图标 以保存这些更改。

6.1.3 测试过滤器

Designer 附带了一个名为策略模拟器的工具,利用该工具,无需在生产环境中实施策略便可对这些策略进行测试。修改策略后,您可以通过过滤器编辑器起动策略模拟器,以测试策略。

  1. 在工具栏中单击“起动策略模拟器”图标 。

  2. 选择“导入”以浏览至模拟事件的文件。

    策略模拟器
  3. 选择文件,然后单击“打开”。本示例使用 com.novell.designer.idm.policy\simulation\add\User.xml 文件,该文件模拟用户对象的添加事件。

    策略模拟器

    策略模拟器显示用户添加事件的输入文档。

  4. 单击“下一步”开始进行模拟。

    策略模拟器

    策略模拟器显示添加事件的日志、输出文档和输入文档与生成的输出文档的比较。

  5. 选择“跟踪”选项卡将显示添加事件的结果,如 DSTRACE 中所示。

    策略模拟器
  6. 选择“输出”选项卡以查看对输入文档执行过滤时生成的输出文档。输入文档就是用户添加事件。

    策略模拟器

    可以编辑输入文档和输出文档。如果要保留更改,请单击“另存为”。

  7. 选择“比较”选项卡以对输入文档的文本与生成的输出文档进行比较。

  8. 单击“重复”以选择其它输入文档并查看该事件的结果。

  9. 完成测试过滤器时,请单击“完成”以关闭策略模拟器。

6.1.4 查看过滤器 XML 源

在 Designer 中,您可以使用 XML 编辑器或文本编辑器来查看、编辑和验证 XML。

查看 XML 源

可以查看 XML 格式或 XML 树格式的 XML 源。

要打开 XML 源视图,请执行以下操作:

  1. 在过滤器编辑器工作空间的底部单击“XML 源”。

XML 编辑器可以显示行号。要查看行号,可以右击左边距,然后选择“显示行号”。

Figure 6-2 过滤器显示行号

XML 编辑器可以按函数展开或折叠 XML。如果函数中包含大量 XML,可以通过单击左上角的减号图标折叠 XML。要展开所有 XML 函数,请单击左上角的加号图标。

在左边距中,每个要素都有其各自的加号或减号图标。

Figure 6-3 过滤器 XML 加号或减号

要以树格式查看 XML,请执行以下操作:

  1. 在过滤器编辑器工作空间的底部单击“XML 树”。

要查看整个树视图,请展开列出的每一项。

编辑 XML 源

可以通过 XML 编辑器来编辑 XML。可以在此处进行更改,也可以通过 GUI 界面来进行更改。

Figure 6-4 编辑过滤器的 XML 源

加载的默认编辑器与 .xml 文件类型相关联。如果找不到默认编辑器,则装载系统文本编辑器。XML 源视图的功能取决于所加载的编辑器。

右击以显示 XML 编辑器所包含的功能列表。

  • 复原: 复原上一操作。

  • 还原文件: 将文件还原为所保存的上一版本。

  • 保存: 保存文件。

  • 剪切: 剪切所选信息。

  • 复制: 将选定的信息复制到剪贴板。

  • 粘贴: 将信息粘贴到文档中。

  • 右移: 将本行向右缩排。

  • 左移: 将本行向左缩排。

  • 挂接 DTD 或 XML 纲要: 挂接 DTD 或 XML 纲要文件以验证策略。

  • 验证: 验证 XML 代码。

  • 自选设置: 设置 XML 编辑器的自选设置。

要为 XML 源视图选择不同的 XML 编辑器:

  1. 单击主菜单中的“窗口”>“自选设置”。

  2. 单击“常规”>“编辑器”>“文件关联”。

  3. 从文件类型列表中选择 *xml。

  4. 从“关联的编辑器”中,选择希望使用的编辑器(例如,Novell XML 编辑器)。(如果列表中没有您需要的编辑器,可以单击“添加”,然后将其添加到列表中。)

  5. 单击“确定”。

  6. 关闭并重新打开过滤器编辑器。将在“XML 源”视图中加载默认编辑器。

验证 XML 源

XML 编辑器可以验证 XML 代码。右击并选择“验证”。如果存在错误,则出现错误的行将显示一个红色的 x。窗口底部的解释将提供有关该问题的详细信息。

Figure 6-5 验证过滤器

本示例中,丢失了起始标签和 <filter-attr> 的首字母。

6.1.5 附加的过滤器选项

右击过滤器对象时,在“大纲”视图、“策略流程”视图和“策略集”视图中将出现多个选项。

“大纲”视图的附加选项

  1. 在“大纲”视图中,右击过滤器对象。

    • Live Operations(实时操作)>“部署过滤器”: 将过滤器部署到 Identity Vault 中。

    • 清除: 从过滤器策略中删除所有内容,但保留对象。

    • 编辑: 起动过滤器编辑器。有关详细信息,请参见Section 6.1.2, 编辑过滤器。

    • 另存为: 将过滤器另存为 .xml 文件。

    • 模拟: 起动策略模拟器。有关详细信息,请参见Section 6.1.3, 测试过滤器。

策略流程视图的附加选项

  1. 在“策略流程”视图中,右击过滤器对象。

“策略集”视图的附加选项

  1. 在“策略集”视图中,右击过滤器对象。

    • 清除: 从过滤器策略中删除所有内容,但保留对象。

    • 编辑: 起动过滤器编辑器。有关详细信息,请参见Section 6.2.2, 编辑过滤器。

    • 保存: 将过滤器另存为 Xml 文件。

    • 模拟: 起动策略模拟器。有关详细信息,请参见Section 6.1.3, 测试过滤器。

    • “实时操作”>“部署过滤器”: 允许您将过滤器部署到 Identity Vault 中。