6.5 Working with Address Books

6.5.1 Opening an Address Book

To open an address book, click Address Book toolbar icon on the Main Window toolbar. The left pane lists the GroupWise Address Book, LDAP Address Book, Frequent Contacts address book, and any personal address books you have created.

You can use File > Open Book and File > Close Book to display and hide the address books in this pane. The right pane lists all the entries in the selected address book.

In an address book, you can open contacts to view details, select names to send an item to, create and modify groups, and create and delete contacts.

You also have advanced options, such as creating and modifying personal address books, changing the properties of an address book, defining copy options, importing and exporting address books, sharing address books, adding directory services, printing labels, and more.

6.5.2 Creating a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click File > New Book.

  3. Type a name for the new book, then click OK.

6.5.3 Editing a Personal or Frequent Contacts Address Book

In a personal address book, including the Frequent Contacts address book, you can add or delete entries, edit existing information, copy names from one book to another, or rename a book. You can also create your own custom address book fields.

Quickly Adding Contacts to Your Personal Address Book

You can quickly add any recipient in an item to any personal address book.

  1. Open an item addressed to one or more recipients.

  2. Right-click the recipient you want to add to a personal address book.

  3. Click Add To Address Book, then click the address book to add the contact to.

Editing Entries in a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click an address book, then double-click the name you want to edit.

  3. Edit the information on the different tabs, then click OK.

Copying Entries between Personal Address Books

When you copy an entry from one address book to another, the entries are linked, so that if you edit one entry, the other entry is also updated.

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click an address book, then click or Ctrl+click the names you want to copy.

  3. Click Edit > Copy To.

  4. Select the address book you want to copy the names to, then click OK.

NOTE:You cannot copy entries to a closed address book; you must open the book first. You cannot copy names to the GroupWise Address Book.

Defining Custom Fields in a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the personal address book where you want to define custom fields.

  3. Double-click an entry, then click the Advanced tab.

  4. Click Add, then type a title for the field in the Field Name field.

  5. In the Value field, type the information you want to display in the field for that entry.

  6. Click OK.

After you have added a custom field to an address book, the field cannot be deleted. However, because custom fields are displayed as columns, you can remove the column from your display. Because each address book can have different columns displayed, the column must be removed from each address book individually.

Deleting Entries from a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click an address book, then click or Ctrl+click the names you want to delete.

  3. Press the Delete key, then click Yes.

6.5.4 Renaming a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the personal address book you want to rename.

    You cannot rename the Frequent Contacts address book.

  3. Click File > Rename Book.

  4. Type the new name, then click OK.

6.5.5 Copying a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the personal address book you want to copy.

  3. Click File > Save As Book.

  4. Type a new name for the address book, then click OK.

6.5.6 Deleting a Personal Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the personal address book you want to delete.

  3. Click File > Delete Book, then click Yes.

After it is deleted, a personal address book cannot be recovered.

NOTE:You cannot delete the Frequent Contacts address book.

6.5.7 Setting Address Book Properties

You can choose and view various properties and options for your address books.

Setting Personal Address Book Properties

Use the Address Book Properties dialog box to view the properties of each of your address books (including the GroupWise Address Book). There are three property tabs in the address books; not all of them are visible from every address book.

The General tab is visible from all address books. Use the General tab to view the name of the address book, a summary of what the address book contains, and so forth. You can also use it to add a description of the address book.

The Options tab is visible only from the Frequent Contacts address book. Use the Options tab to specify what is saved in Frequent Contacts and how this address book should be cleaned up. See Setting Frequent Contacts Properties.

The Sharing tab is visible for personal address books for which you are the owner, including your Frequent Contacts address book. Use the Sharing tab to choose whether or not to share an address book, who to share it with, and which access rights each person should have.

You can also share your personal groups by placing them in an address book you share with others.

Viewing an Address Book’s Properties

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the address book you want to view the properties for.

    If the book is not visible, the book is not open.

  3. Click File > Properties.

  4. To view the number of individuals, resources, companies, and so forth, click Contains.

    If the address book is large, this might take some time. The status bar measures the progress of this operation.

  5. To add or modify a description for the address book, click the Description field, then type or edit the description.

  6. Click OK to save your changes and close the Properties dialog box.

    or

    Click Apply to apply your changes and keep the Properties dialog box open.

Setting Frequent Contacts Properties

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the Frequent Contacts address book.

  3. Click File > Properties, then click the Options tab.

  4. Select the options you want.

    If you cannot change these options, your GroupWise administrator has locked them.

    To stop names from being placed into the Frequent Contacts address book, click Auto-saving off.

  5. To delete names from this book, select the Delete addresses not referenced within time period check box, type a number in the Time period field, click a time period from the drop-down list (from hours to years), then click Delete Now to remove old addresses.

  6. Click OK to save your changes and close the Properties dialog box.

    or

    Click Apply to save your changes and keep the Properties dialog box open.

6.5.8 Using Predefined Filters for the Frequent Contacts Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the Frequent Contacts address book.

    If the Frequent Contacts address book is not visible, you can open it by clicking File > Open Book.

  3. Click View > Filter for at Least 3 References.

    or

    Click View > Define Filter for References (a reference is the number of times you have sent or received items from an entry), type the minimum number of references an entry must have in order to be included in the search criteria, then click OK.

6.5.9 Sharing an Address Book with Another User

Shared address books are marked with a Shared address book icon icon. This icon might be slightly different, depending on whether or not you created the address book.

You can share personal address books with other users. You can give users read-only rights, or you can give them rights to read, add, edit, and delete information in the address book. When you share an address book, the users receive a notification that they can accept or decline.

GroupWise places no limit on the number of recipients with whom an address book can be shared. Similarly, there are also no GroupWise limitations on the number of entries that can be contained within a Shared Address book.

NOTE:Because system performance depends on the hardware being used to run GroupWise, sharing an address book with many users or having an extremely large amount of entries within a Shared Address book can cause performance issues.

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Right-click the address book you want to share, then click Sharing.

    If the address book is not visible, you can open it by clicking File > Open Book.

  3. Click Shared with.

  4. Type the name of the person you want to share the address book with, then click Add User to add the user to the Share list.

    If you do not know the name of the person, click Address Book icon, then search for and select the user.

    You cannot share address books across external domains.

  5. Click each user’s name in the Share list, then assign him or her access rights in the Access group box.

  6. Click OK to save your changes and close the dialog box.

    or

    Click Apply to apply your changes and keep the dialog box open.

    When you click OK or Apply, the person you are sharing the address book with receives a notification. The Status column displays as Pending until the user accepts or declines the shared address book request; then the column is updated to reflect the user’s selection.

    In the Address Book list, shared address books are marked with the Shared address book icon icon.

    You and the users you share an address book with can arrange your address book columns differently.

6.5.10 Accepting a Shared Address Book

When you accept a shared address book, it appears in your Address Book List along with the GroupWise Address Book, Frequent Contacts address book, and personal address books.

  1. Click the Mailbox icon in the Folder List.

  2. Click the shared address book notification to open it, or right-click it, then click Open.

  3. Click Accept Address Book to add the address book to the address book list.

You can now use the shared address book to address items or look up user information, just as you would in other address books.

6.5.11 Synchronizing Address Book Entries

You can use Synchronize to ensure that your personal address book entries match the corresponding entries in the GroupWise Address Book. You can synchronize an entire personal address book or just the entries you have selected.

For example, you might have a personal address book containing the names of your contacts in the Marketing department. When the Marketing department changes buildings and phone numbers, Synchronize saves you from needing to create a new personal address book.

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the personal address book you want to synchronize.

  3. To synchronize an address book, click File > Synchronize > Current Book.

    or

    To synchronize selected entries, Ctrl+click or Shift+click the entries, then click File > Synchronize > Selected Items.

6.5.12 Displaying Quick Info

Summary information about users is displayed in an address book and in the Address Selector when you mouse over that name. This display is called Quick Info.

Quick Info is enabled by default. To disable Quick Info:

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click View > Disable Quick Info.

6.5.13 Viewing Contacts, Groups, Organizations, or Resources in an Address Book

Use the predefined filters in the Entry Filter to display only groups, users, organizations, or resources in an address book.

By default, address books display all entries. Although all groups, organizations, and resources are marked by icons, finding specific entries in large address books can be a challenge. Using a predefined filter displays only the type of entry you are looking for.

There is one predefined filter that applies only to the Frequent Contacts address book: Filter for at Least X References. You can use it to filter all entries with at least the number of references you specify.

To view groups, organizations, or resources in an address book:

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click an address book.

  3. Click View, then click the filter you want to sort by.

  4. To return to the non-filtered address book view, click View > Filter Off.

To filter for contacts, groups, and resources:

  1. In the Address Selector, click a predefined filter from the Filter icon drop-down list to filter for contacts, groups, and resources.

    The following icons identify contacts, resources, groups, and organizations in address books:

    Contacts icon Contacts

    Resource icon Resources

    Group icon Groups

    Organization icon Organizations

6.5.14 Editing a Distribution List in the GroupWise Address Book

If your GroupWise administrator has granted you rights to modify a public distribution list in the GroupWise Address Book:

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

    or

    Click Address on the toolbar in an item you are composing.

  2. Select the GroupWise Address Book.

  3. Double-click the public distribution list that you have rights to edit.

  4. Make changes as necessary.

  5. Click Close, then click Yes to save your changes.

6.5.15 Searching for Address Book Entries

You can quickly find entries in an address book by using the Search List. You can also specify search criteria by defining one or more filters. For example, you can define a filter that displays only entries with last names that begin with “D.”

Searching for Users, Resources, Organizations, and Groups

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

    or

    Click Address on the toolbar in an item you are composing.

  2. Select the address book you want to search.

  3. In the Look For field, begin typing what you are searching for.

    Name Completion completes the name.

Using Filters to Narrow an Address Search

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click View > Define Custom Filter.

  3. Click the first drop-down list, then specify the column you want to filter.

  4. Click Operator List icon , then specify an operator.

    An operator is a symbol used with a condition to specify a particular value. For example, to create a filter that lists only users whose last name is Davis, click the Last Name column, click = Equal To, then type “Davis.” In this example, = Equal To is the operator and Davis is the condition.

    For more information, see Using Advanced Find.

  5. Type the condition you want to filter by, then click OK.

    The filtered search sorts the address book according to the results it found.

After a filter has been defined for an address book, you can enable the filter whenever you want by displaying the address book in which you want to enable the filter and then clicking View > Custom Filter. Clicking OK enables it; it remains in effect until you turn it off or delete it.

6.5.16 Customizing an Address Book Display

You can control which address books are displayed in the Address Book list by opening and closing address books. For example, you might have a personal address book for an account that you deal with only six months out of the year. You can close it when you don’t need it and open it again six months later.

You can also control the information that is displayed in a single address book. In order for you to change displayed information in an address book, that address book must be open.

Opening and Closing Address Books

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click File > Open Book.

    If all of your address books are open, Open Book is dimmed.

  3. Click or Ctrl-click one or more address books, then click OK.

  4. To close an address book, select the address book, then click File > Close Book.

    Closing an address book does not delete it; you can open it again at any time.

Specifying the Columns to Display in an Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

    or

    Click Address in an item you are composing.

  2. Click the address book where you want to change the displayed columns.

  3. Right-click a column heading, then click a column name.

    If the column name is not displayed, click More columns. To add a column, click the column in the Available columns list box, click Add, then click OK.

  4. To remove a column, drag the column heading off the address book.

  5. To arrange columns, drag a column heading to another position.

Viewing Links to the GroupWise Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the personal address book where you want to view links.

    A linked contact in an address book is shown with the Linked contact icon icon.

  3. Click View > System Book Links to select it.

    Links show that an entry in a personal address book is linked to an entry in another book. When one is updated, the other is also updated. Links are created when you copy an entry from one address book to another. Links are also created when entries from the GroupWise Address Book are added to your Frequent Contacts address book because correspondence has occurred.

Choosing the Display Format of Names

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click View > Name Format.

  3. Click a radio button to display address books by first name first or last name first.

  4. Ctrl-click the personal address books you want the format to apply to.

  5. Click Apply to selected books to apply these changes without exiting the dialog box.

    or

    Click OK to apply these changes and exit the dialog box.

6.5.17 Sorting an Address Book

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the address book you want to sort.

  3. Right-click the column you want to sort by, then click Sort on ‘column’ First (for example, sort by the Email Address column rather than by the Name column).

    or

    Right-click any column heading, click Sort All Ascending (for example, A to Z or 1, 2, 3) or Sort All Descending (for example, Z to A or 3, 2, 1) to sort the column entries.

6.5.18 Importing and Exporting Addresses and Address Books

Use the Import and Export features to transfer your existing GroupWise and third-party address books into and out of a GroupWise personal address book. GroupWise address books are best exported in .nab format should be used to avoid information loss. Importing address books is also more accurate if the .nab format is used. You can also import and export your personal groups.

You can also share personal address books. See Sharing an Address Book with Another User.

Importing a GroupWise Personal Address Book into a Personal Address Book

GroupWise address book files are text files with specific formatting. GroupWise 18 .nab files use UTF-8 character encoding and cannot be imported into earlier versions of GroupWise. However, GroupWise 18 can export .nab files in ANSI character format, which is compatible with earlier versions of GroupWise. The .nab files created by earlier versions of GroupWise can be imported into GroupWise 18.

NOTE:You cannot import addresses into the GroupWise Address Book.

  1. If you have received a GroupWise personal address book (.nab file) as an attachment, right-click the attachment, click Save As, select the folder or disk where you want to save it, then click Save.

  2. In the Main Window, click Address Book toolbar icon on the toolbar.

  3. Click File > Import.

  4. Select the address book .nab file, then click Open.

  5. Click the address book you want to import addresses into.

    or

    Create a new personal address book to import the addresses into.

    For more information, see Creating a Personal Address Book.

  6. Click OK.

  7. (Optional) To stop the import, pres Esc, then click Yes.

Importing Contacts from a vCard

A vCard can contain either a single contact or multiple contacts. GroupWise supports either format.

To import information into an address book from a vCard you have received:

  1. Right-click the vCard, then click Import.

  2. Click the address book where you want the information to be added, then click OK.

Importing Third-Party Address Books

Importing Contacts with a CSV File

To import a CSV (comma-separated values) file:

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click File > Import.

  3. Select the .csv file, then click Open.

  4. Select the address book you want to import addresses into, then click OK.

    or

    Click New to create a new personal address book to import the addresses into, type a name for the new address book, then click OK.

    For more information, see Creating a Personal Address Book.

    The Choose GroupWise Fields for CSV Data window is displayed.

    The CSV Fields column lists the data fields as provided in the .csv file. The CSV Data column lists the data provided in the .csv file. The GroupWise Fields column lets you choose the associations between CSV fields and GroupWise fields.

    By default, the import process can recognize characters such as comma (,), semicolon (;), and colon (:) as field delimiters. It can also recognize characters such as quotation marks (") as text delimiters. However, if unusual characters are used as delimiters, the import process won’t recognize them.

  5. If the .csv file does not display in proper columns:

    1. Click Options.

    2. Change the field delimiter character as required by the .csv file.

    3. Change the text delimiter character as required by the .csv file.

      The .csv file should redisplay in proper columns.

  6. Click the left and right arrows to page through the .csv file data.

    The import process attempts to assign the CSV fields to GroupWise fields.

  7. To change an automatic field assignment, click the GroupWise field link that you want to change.

    or

    To select a field assignment, click the Click to choose link.

  8. Select a displayed field.

    or

    Click a field category, then select the GroupWise field that you want to correspond to the .csv file field.

  9. To not import the data from a CSV field, click the link in the GroupWise Fields column, then click Clear.

  10. When you are finished assigning field mappings, click OK to import the CSV data into the selected address book.

HINT:You can also initiate an import by dragging and dropping a .csv file into a Contacts folder.

Exporting Addresses from the Address Book

To export addresses from an address book in NAB (GroupWise Address Book) format:

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the address book from which you want to export names.

  3. Select the addresses you want to export.

    If you want to export an entire address book, you don’t need to select any names.

  4. Click File > Export.

  5. Click Entire Address Book if you want to export the entire address book.

    or

    Click Selected Items if you want to export the addresses you have selected.

  6. Click OK.

  7. Type a file name for the exported file, then click a folder where you want the file to be saved.

  8. In the Save as type drop-down list, select the file type to save the addresses as.

    You can save the file as a GroupWise Address Book (.nab), a vCard (.vcf), or a comma-separated file (.csv).

    GropWise address book files are text files with specific formatting. GroupWise 18 .nab files use UTF-8 character encoding and cannot be imported into earlier versions of GroupWise. However, GroupWise 18 can export .nab files in ANSI character format, which is compatible with earlier versions of GroupWise.

    The .nab and .vcf file types are preferred because they handle complex data without loss. For example, if you export a distribution list as a .nab or .vcf file, members of the distribution list are included in the exported file. However, if you export a distribution list as a .csv file, only the name of the distribution list is exported.

  9. Click Save.

To stop the export, press Esc, then click Yes.

6.5.19 Using the LDAP Address Book

Adding a Directory Service to an Address Book

  1. Ensureensure you know the server name and port number of the LDAP directory service. You can get this information from your Internet service provider or GroupWise administrator.

  2. In the Main Window, click Address Book toolbar icon on the toolbar.

  3. In the left pane, click LDAP Address Book.

  4. In the right pane, click Directories, then click Add.

  5. Follow the prompts. When you specify the server address, you can specify an IP address or Internet domain name.

  6. Click Finish.

  7. If you are adding a directory service to search for security certificates, the directory service must be set as the default. Click the directory service account you just added, then click Set as Default.

  8. Click Close.

Searching for a Person through a Directory Service

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the LDAP Address Book.

  3. Select a directory service from the Look In drop-down list.

  4. Type the name you want to search for.

    or

    Type an email address you want to search for.

    If other search fields are available, specify the information you want to search for.

  5. Click Retrieve.

  6. When the search is complete, double-click the name you want.

  7. Click Close.

If you want to save the names you find in the search, click the names, click Edit > Copy To, select a personal address book, then click OK.

Establishing a Secure Connection to a Directory Service

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the LDAP Address Book.

  3. Click Directories, then click a directory service.

  4. Click Properties.

  5. Click Connect using SSL.

  6. Specify the path to your digital certificate file.

    This file enables GroupWise to use SSL to authenticate to the LDAP server (that is, the directory service) you have chosen. Contact your GroupWise administrator to learn the location of this certificate file, or obtain a certificate file from your Internet service provider. You can click the Browse button to find the exact location of the file.

    NOTE:GroupWise expects a DER encoded certificate file to be used when establishing a secure connection to the LDAP server.

Modifying the Properties of a Directory Service

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the LDAP Address Book.

  3. Click Directories, then click a directory service.

  4. Click Properties.

  5. Click the Connection, Searching, and Field Mapping tabs to find the properties you want to modify.

  6. Modify the properties, then click OK.

Specifying the Search Criteria a Directory Service Uses

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the LDAP Address Book.

  3. Click Directories, then click a directory service.

  4. Click Properties.

  5. Click the Searching tab, then click Search Fields.

  6. Select up to four fields.

    Many directory services allow you to search using only the Name and Email Address fields.

  7. To add search fields that aren’t listed:

    1. Click the Field Mapping tab, then click Retrieve All LDAP Fields.

    2. Click Apply, click the Searching tab, click Search Fields, then select the fields you want to search.

      The available search fields depend on the selected directory service.

  8. Click OK twice, then click Close twice.

Changing the Length of Time for Directory Service Searches

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click the LDAP Address Book.

  3. Click Directories, then click a directory service.

  4. Click Properties, then click the Searching tab.

  5. Drag the bar under Amount of time to search before timing out until it shows the amount of time you want.

  6. Click OK > Close > Close.

6.5.20 Advanced Address Book Options

Defining Copy Options

Use Copy Options to select the format to use when you copy address book data to the clipboard. When the address book data is copied to the clipboard, it is formatted as a virtual business card (vCard) or address book text. A vCard includes all identifying information for an individual who is included in an address book.

There are two copy format options: Display Data (ASCII text format) and vCard Data (.vcf stream format). When you select a format, the vCard data is with the standard Windows text-copy procedure (select text, then press Ctrl+C), and can be pasted in that format into other applications (such as personal information managers and web applications) to fill your particular needs.

For example, you could paste the display text into an HTML editor or a word processor for import into a database or for formatting as a mail merge document. Or, if you chose to copy in vCard format, you could paste the data into a vCard editor or viewer to include sound clips, graphics, or additional text. You could also save the data as a .vcf file for import into any other application that supports the vCard standard. GroupWise supports up to version 2.1 of the vCard standard.

To select the text format to use for copying:

  1. In the Main Window, click Address Book toolbar icon on the toolbar.

  2. Click Edit > Copy Options.

  3. Select the copy option you want.

    The Display data option copies text as “display” text. The vCard data option renders text as a vCard data stream.

  4. To make your current selection the default, select the check box.

  5. Click OK.