Designer 2.1 for Identity Manager 3.5.1: Readme

August 20, 2007

For the latest version of the Readme, visit the Designer 2.1 documentation Web page.

1.0 Documentation

1.1 Where to Find Information

The documentation for Designer 2.1 for Identity Manager 3.5.1 is included with the software, in the help system. It is also available online at the Novell Designer 2.1 documentation Web site.

For the latest, updated documentation on Designer 2.1, see the Novell Designer 2.1 documentation Web site.

For information on Novell® Identity Manager 3.5.1, visit the Identity Manager 3.5.1 Documentation Web site.

1.2 Browsing or Searching

To browse the Designer help topics after Designer is installed:

  1. In Designer, click Help > Help Contents.

  2. Select a book, browse the table of contents, then click a topic.

To search for specific Designer information after Designer is installed:

  1. Click Help > Search, then enter text. Or press F1 on any page. (In Linux, press CTRL-F1.)

  2. Type a topic in the Search field, then click Go.

1.3 F1 Help in Maximized Editors

If you maximize an editor (for example, the Modeler), help topics do not display when you press F1. To view the help, minimize the editor.

1.4 Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items in a cross-reference path.

A trademark symbol (® , TM, etc.) denotes a Novell trademark; an asterisk (*) denotes a third-party trademark

2.0 Localization

2.1 Available Languages

This release of Designer includes User Interface translation for Brazilian Portuguese, Chinese (Simplified), Chinese (Traditional), Dutch, French, German, Italian, Japanese, and Spanish. You can select the User Interface language during installation, or at runtime through the preferences dialog box.

2.2 Nontranslated Components

This release does not include translation of Designer runtime help or product documentation.I rec

2.3 Plug-Ins

Some plug-ins are provided by the metadirectory and are available only in languages supported by the metadirectory: Chinese (Simplified), Chinese (Traditional), French, German, and Japanese. Some third-party plug-ins might be available only in English.

3.0 Generating Documentation for Projects

3.1 Chinese or Japanese PDF Is Not Displaying Properly When Using the Linux PDF Reader (Evince)

By default, Linux might be using a PDF reader (Evince) that doesn't support the embedded font we use to display double-byte characters. We recommend that you use the Adobe Acrobat Reader for Linux.

3.2 Error: "Out of Memory" When Generating Documentation on Windows

Some Windows users have experienced an Out of Memory error when generating documentation. To fix this:

  1. Right-click the Designer shortcut, then select Properties.

  2. Make sure that the -vmargs -Xms256m -Xmx1024m parameters are not enclosed in quotes.

    Only the path to the designer.exe file must be in quotes. The following example illustrates the path:

    " C:\Program Files\Novell\designer\eclipse\designer.exe" -vmargs -Xms256m -Xmx1024m

    If you still experience problems, you can attempt to adjust the -Xms256m -Xmx1024m parameters to a higher memory amount. Just make sure that your system has that memory available. The default settings should be sufficient for most applications.

    For more information, see "Freeing Heap Memory" in the Designer help.

3.3 Backward Compatibility for Document Generation Styles

Designer 1. x versions of Document Generation styles are not compatible with Designer 2.1. We recommend that you create a new style, then copy and paste your data from the old style. Otherwise, you miss new functionality found in 2.1 styles.w

4.0 Encryption and Security

4.1 Project Files Not Encrypted

Passwords are obfuscated. However, if you have other sensitive data in your project file, it is not encrypted in any way, and you must take care to safeguard your information. In the future, the data will be protected.

4.2 Clear Text in Policy Builder

IMPORTANT:When you use any action that might require a password to be entered (for example, Do Send Email), the password is not being encrypted with this release. If you deploy the policy or save it to disk, the password is in clear text

5.0 General Issues

5.1 Policy Simulation Stops Working after Designer Upgrade

If simulation stops working after a Designer upgrade, and you are unable to progress past the query/response stage of processing, you can remedy the situation by checking and correcting your simulator preferences page settings. To do this:

  1. Select Window > Preferences > Designer for IDM > Simulation.

  2. Verify that all paths specified for Input, Output, and Java Extensions are valid paths and that they exist.

5.2 Notification Templates Are Filtered by Name and Locality Settings

When running Designer in any language, by default you see only notification templates for the language that you are running in. To see templates in additional languages, change the filter settings for the Outline view:

  1. Click the filter icon in the upper right corner of the Outline view.

  2. Select the languages that you want to see.

Also, when creating templates, you must add the proper language code to the template name so that your new templates are filtered correctly.

For example, a German template should be named <TemplateName_de>. The language codes are as follows:

  • de-German

  • es-Spanish

  • fr-French

  • it-Italian

  • ja-Japanese

  • nl-Dutch

  • pt-Portuguese

  • ru-Russian

  • sv-Swedish

  • zh-CN-Chinese Simplified

  • zh-TW-Chinese Traditional

English Templates are not named with a code.

5.3 Designer Will Not Launch after Installation on Windows Vista

Windows Vista has implemented a new User Account Control feature that prevents applications to run as Administrator unless you specifically allow it. To run Designer in Vista:

  1. Right-click the Designer shortcut.

  2. Select Run as Administrator.

5.4 Java Heap Status Widget Does Not Display When You First Run Designer

The first time that you run Designer, the Heap Status Widget does not display. To display it, restart Designer. This is a known Eclipse issue.

5.5 Fixing a "java.lang" Error

When importing a project, you might see the java.lang.NoClassDefFoundError: org/apache/xml/serialize/XMLSerializer error in the error log. If you see this error in the error log reinstall Designer to again lay down the xerces.jar file.

5.6 Project Backward Compatibility in Designer

Projects created in Designer 2.0 and 2.1 are not compatible with earlier versions of Designer. In this release, if you use a project created earlier than Designer 2.0, Designer runs a project conversion.

5.7 Save Custom XDS Documents before Upgrading or Reinstalling

WARNING:By default, preferences for policy simulation output are saved to the plug-in directory. If you run Designer 1.2 or earlier and save your custom XDS documents to the plug-in directory, the documents are deleted if you upgrade to Designer 2.1 or reinstall Designer 2.1.

To prevent custom XDS documents from being deleted, save them to some other directory than the plug-in directory. For example, save them to the workspace directory or change the default output directory to the workspace directory.

5.8 Minimum Resolution Required for Designer

The minimum resolution required for Designer is 1024 x 768. The recommended resolution for Designer is 1280 x 1024.

5.9 Trace Options Might Disappear from Trace Preferences on the Novell Linux Desktop

On the Novell Linux Desktop, some themes can cause display issues for Designer. One issue is the inability to see the available plug-ins to trace when tracing is disabled. This problem is most widely seen with the Industrial theme.

To work around this issue, change your theme to one of the following:

  • Grand Canyon

  • Mist

  • Traditional

5.10 Protecting Your Project Files and Project Data

It is a good practice to protect your work by periodically saving your project. You can easily make a copy:

  1. Right-click a project in the Project view.

  2. Select Copy Project.

  3. Name the project, then click OK.

In the rare event that Designer gets into a questionable state (for example, lines aren't drawing correctly), as an extra precaution, don't save the project. Close the project, reopen it, and then resume your work. By not saving, you avoid the possibility of saving a corrupted project.

5.11 Application Schema Not Imported by Default

With this release of Designer, an application schema is not automatically imported by default. You can always refresh the application schema on a particular application after the project has been imported:

  1. Select the driver.

  2. Select Live > Refresh Application Schema.

You can also change the default by setting a preference:

5.12 Running Designer with 120 DPI Fonts in Windows

120 DPI is too large for text in standard Windows XP decorations. Adjust the Display settings:

  1. In the Control Panel, select Display > Appearance > Effects.

  2. In Use the following method to smooth edges of screen fonts, toggle Standard to ClearType.

    If you have a display that necessitates 120+ DPI fonts, you need ClearType.

    Besides the obvious anti-aliasing aspects, ClearType gives fonts better weight. Without ClearType, the fonts are too thin and light, decreasing readability.

  3. Click OK, then click Advanced.

  4. In the Item field, reduce the Icon, Menu, Message Box, Selected Items, and ToolTip sizes.

  5. Reduce title bars and related controls to a preferred size.

  6. Fix icon spacing and scroll bar width.

  7. Make sure that you are running at a very high resolution.

    This helps eliminate most of the display issues on an HD monitor.

5.13 Boosting Modeler Performance

If you want to maximize the performance on large-scale operations (for example, copy/paste of several objects), you will find that the performance is up to ten times faster if you hide or close the Outline view. You get even better performance if you also close the Properties view. To quickly restore these views, click Window > Reset Perspective.

5.14 Enabling Identity Manager 3.5.1 Features

This release of Designer supports the new features introduced in Identity Manager 3.5.1 Identity Manager 3.5.1 features are enabled by default on all new projects. The default Identity Manager server version for all new projects is 3.5.1 This is placed in the server properties page so that you can get access to the new 3.5.1 feature set. To access the server properties page:

  1. Go to the Outline view.

  2. Double-click the server icon.

For more information, see the Help system.

6.0 Installation

6.1 Installation on Windows Vista

Designer 2.1 is not officially supported or tested on Windows Vista. However, our initial impression is that Designer runs well on Vista. During the install, you see a message stating that you are installing on an unsupported Windows version. You can continue with the installation by selecting OK. For instructions on running Designer on Vista, see Section 5.3, Designer Will Not Launch after Installation on Windows Vista.

6.2 Installing to Double-Byte Install Path on English Windows with the East Asian Language Pack

When installing to a path where there are double-byte characters, and if your operating system is running the English version of Windows with the East Asian Language Packs installed, an error message informs you that the install is unable to extract the compressed file.

There are known issues with using double-byte character sets (DBCS) in Windows file paths. We cannot provide a fix at this time; the fix would have to come from the OS vendor or the install framework vendor. As an alternative, you can install to DBCS paths when installing to a localized version of the operating system.

6.3 The Designer Install Crashes on SLED 10, SuSE 10.2 with XGL Desktop

There are known cases when the Designer install crashes when installing on SLED 10 and SuSE 10.2 when XGL is enabled. The error might be displayed as:

An unexpected error has been detected by HotSpot Virtual Machine:

The problems are only seen when XGL is enabled. If XGL is enabled, disable it, then try installing again.

6.4 Install Dependencies for NDSBase and NICI

When you install on Linux, supporting Linux packages for Designer are needed. The GNU gettext utilities provide a framework for internationalized and multilingual messages. Before installing Designer, make sure you have installed the gettext package and any dependencies for this package. You can use YaST to check for installed packages and to check dependencies.

6.5 Designer Installs Its Own JRE

The installation installs a JRE specifically for Designer. This JRE won't impact Java* installed for other uses on the workstation.

6.6 Unable to Install Designer on Windows

Some users have reported the inability to install Designer on Windows*. The install starts to run but closes with the following error:

This application has unexpectedly quit.

If you see this message, do the following:

  1. Right-click the Designer install.exe file, then select Properties.

  2. Select the Compatibility tab.

  3. Under the Compatibility mode section, select Run this program in compatibility mode.

  4. Select Windows 2000 from the drop-down menu.

The Designer install should execute normally.

6.7 During a Linux Install, Root Privileges Are Required

Installing eDirectory™ base components and NICI requires root privileges. The install program prompts you for the root password so that you can install these components.

6.8 On Linux, the Install Displays an Exception Error

The following error occurs with some versions of Linux:

Invocation of this Java Application has caused an InvocationTargetException. This application will now exit.

The xhost program makes Linux more secure by not allowing other hosts and users to make connections to the X server. If you are logged in as a valid user and are trying to run the install as root, this error can occur. For more information on xhost, refer to the man page for xhost.

6.9 On Linux, Resizing the Process Window after the Pre-Installation Summary Halts Installation of Designer.

This is a problem with the underlying install framework that Designer uses. The issue is being tracked and addressed by the third-party company responsible for that install framework.

7.0 Linux-Specific Issues

7.2 Opening External Links on the Readme Displayed at End of the Designer Install

Our installation framework provided by Macrovision confirms that this is a problem in the install framework. At this time, you must open these links manually

7.3 Running eDirectory with Designer

If you are running eDirectory on Linux and also want to run Designer, you might need to run Designer as root. The eDirectory install requires you to install its base packages as root. This prevents a non root user from running them. Specifically, Designer crashes if you are running as a non root user when importing or deploying and when connecting to a tree.

7.4 Running Designer on Linux

We don't recommend that you use the gtk-qt-engine -GTK-style Engine for Use with Qt Plugins and Settings. This RPM package is installed with SUSE Linux 9.2 and 9.3 and possibly other Linux distributions. Known issues cause crashes and Designer theme issues when this package is installed

If you must use this RPM package, obtain the latest version.You can download this version from

Even with the latest version of the package, Designer theme functionality might not be present

To determine whether you have the gtk-qt-engine - GTK-style Engine for Use with Qt Plugins and Settings RPM package installed, enter:

rpm -qa|grep gtk-qt

If gtk-qt-engine appears in the list, you should remove the package by issuing the following command as the root user:

rpm -e gtk-qt-engine

7.5 If You Encounter Display Issues on Linux

Fixing display issues in GNOME*:

  1. Select the Applications menu.

  2. Click Preferences > Font, then decrease the size of the application font.

    You can also adjust the thematic elements to your liking. Keep in mind that GTK thematic elements can cause performance issues with Designer. If Designer is running slowly, especially when you use pull-down menus and other widgets, you might try changing to a simplified GTK theme.

Normally, this process fixes display issues.

Fixing display issues on KDE:

Because Eclipse (Designer) is a GTK application, we recommend that you use GTK themes rather than qt-based themes.


  • You must remove the gtk-qt-engine package mentioned in section 3.6. You can do this through YaST or by using the instructions given above.

  • You need to have the following packages installed on your Linux system. If you installed the GNOME subsystem, you already have these packages installed:

    • gtk-engines

    • gtk2-engines

    • control-center2 > Gnome Control Center

    • gtk2-themes (or the themes you downloaded, and all the related dependencies)

    • gnome-themes (only needed if you are going to use the Gnome Control Center to set your theme)

Do one of the following:

  • Set your GTK theme and font settings from the KDE SUSE menu.

    Select Utilities > Desktop > Gnome Control Center. You can set this control center application to automatically run each time KDE is started. The following command accomplishes this:

    ln -s /opt/gnome/lib/control-center-2.0/gnome-settings-daemon /home/ user/.kde/Autostart

    For user, use your username.

  • Create a GTK control file (usually named .gtkrc-2.0) in your user home directory or the directory where your system is configured to look for GTK2_RC_FILES. Entering set |grep gtk shows how this environment variable is configured and which files it is looking for. The file should include the following information. You can use any font and GTK theme that you prefer.

    include "/opt/gnome/share/themes/Xfce-stellar/gtk-2.0/gtkrc" style "user-font" { font_name="Sans Serif 6" } widget_class "*" style "user-font" gtk-theme-name="Xfce-stellar" gtk-font-name="Sans Serif 6"

7.6 Launching Designer from the Shell on Linux

The S file sets important variables, permissions, and memory parameters. If Designer isn't launched from this file, Designer won't function correctly or be able to call other programs (for example, Mozilla*) on Linux. is located in the /[path to the Designer install]/designer/eclipse directory.

7.7 Running Designer on Red Hat Fedora

The latest Fedora core ships with new shared libraries that cause problems in Designer. You might see errors in the error log when you try to use Designer's browser functionality or when performing various operations in Designer's editors. To solve this problem, log in as root and issue the following command to install a compatibility library:

sudo yum install

7.8 What's New HTTP Links Not Launching the Browser

Certain links on the What's New page (specifically the Bugzilla links) do not launch a browser on Linux. This is an Eclipse issue that should be fixed in later versions that we will implement into Designer. As a temporary workaround, you can configure your Eclipse preferences to launch an external browser for viewing help files:

  1. Select Window > Preferences > General > Web Browser.

  2. Select Use external Web browser.

  3. Select a browser, then click OK.

8.0 Workflow/Provisioning

8.1 A Form Field That Returns Undefined Does Not Display an Error or Warning

If a field on a form used by a workflow returns the value undefined, the form does not display an error or warning message. This situation results from a problem in the script. In general, if a form script evaluates to undefined, the script is considered to be in error. The workaround is to make sure you do not set undefined in the preactivity mappings. To do this, use a try/catch/finally block to ensure that a valid value is always being sent to each control.

8.2 Possible Timeout When Setting Trustee Rights on a Provisioning Request Definition

You might encounter the following error message when trying to set Trustee rights on a provisioning request definition or when trying to access the Identity Vault via the ECMA expression builder:

Cannot connect to host 'xxx', verify the address is correct and the server is running.

If the address is correct and the server is running, a slow connection might cause this error message.

You can change the connection timeout by setting the Connection preference. Select Window > Preferences > Provisioning.

8.3 Saving Incorrect Credentials in the Provisioning Request Definition Editor

When you connect to the Identity Vault from the provisioning request editor (for example when setting Trustee rights on a provisioning request definition) you are prompted for your Identity Vault credentials. If you type an incorrect password and click the Save password button in the Identity Vault credentials dialog box, you cannot connect to the Identity Vault and you are not prompted to retype your credentials.

To work around this issue, access the Modeler view and reconfigure the Identity Vault credentials for the project.

8.4 Problems Running Designer on Windows XP Using the Windows Classic Theme

If you run Designer on Windows XP using the Windows Classic Theme, you might encounter problems when you tab between radio buttons. The radio buttons disappear. To work around this problem, use the Windows XP theme.

8.5 Misleading Deployment Results Message When Deleting an Entity

If you delete an entity and select Deploy All on the container, the message displayed in the Deployment Results dialog box is misleading. The message indicates that the entity was successfully deployed, not undeployed.

8.6 Wrong Version Number in Documentation for the User Application

When you generate provisioning documentation for a version 3.0.1 or 3.5 User Application driver, the documentation lists the driver as 3.5.1. The version number in the documentation should be 3.0.1 for the 3.0.1 driver or 3.5 for the 3.5 driver.