5.7 Installing or Updating the Clusters Plug-in for iManager

The Clusters plug-in for iManager was reorganized in OES 11 SP1. On the Roles and Tasks page under Clusters, the Cluster Manager, BCC Manager, Cluster Event Log, and Cluster Options menu options have been replaced with two options: My Clusters and My Resources.

Links on the these pages take you to the familiar cluster options presented as tabs: Cluster Manager, BCC Manager, Cluster Event Log, and Cluster Options.

Use the information in the following sections to install or update the Clusters plug-in.

5.7.1 Prerequisites for Installing or Updating the Clusters Plug-In

The Clusters plug-in supports the management of OES and NetWare clusters and resources. It cannot be installed on a NetWare server.

The Clusters plug-in requires the following components to be installed in iManager:

5.7.2 Installing the Clusters Plug-In

If you are installing a new instance of Novell iManager 2.7.5 or later and the Clusters plug-in on a computer, follow the instructions in Downloading and Installing Plug-in Modules in the NetIQ® iManager Administration Guide. Ensure that you install the Clusters plug-in (ncsmgmt.rpm) as well as the common code for storage-related plug-ins (storagemgmt.rpm).

Verify that the /var/opt/novell/iManager/nps/WEB-INF/lib directory contains the class loader file commons-lang-2.6.jar (or later version), then remove all earlier versions of the file. The Clusters plug-in for Novell iManager 2.7.5 requires commons-lang-2.6.jar (or later version) of the class loader file. Novell iManager uses one class loader for all of its plug-ins. If multiple versions of the class loader file exist in the /var/opt/novell/iManager/nps/WEB-INF/lib directory, iManager loads whichever one comes first alphabetically. You must remove the earlier versions (such as commons-lang.jar or commons-lang-2.4.jar) to ensure that iManager loads the 2.6 or later version of the class loader file. Restart Tomcat when you are done.

To configure role-based services for the Clusters plug-in, see RBS Configuration in the NetIQ® iManager Administration Guide.

5.7.3 Uninstalling and Reinstalling the Clusters Plug-In

Use the procedure in this section to update an instance of the Clusters plug-in, or to add the Clusters plug-in on a computer where other storage-related plug-ins are already installed.

  1. In iManager, uninstall the currently installed storage-related plug-ins.

  2. Copy the new version of the plug-in files to the iManager plug-ins location, manually overwriting the older version of the plug-in in the packages folder with the newer version of the plug-in.

  3. In iManager, install all of the storage-related plug-ins, or install the plug-ins you need, plus the common code.

  4. If you are updating the Clusters plug-in, delete the contents of the /var/opt/novell/tomcat6/work/Catalina/localhost/nps work folder.

    You must manually delete the old compiled JSPs that are cached in the nps work folder. This ensures that only the latest files are cached.

  5. Verify that the /var/opt/novell/iManager/nps/WEB-INF/lib directory contains the class loader file commons-lang-2.6.jar (or later version), then remove all earlier versions of the file from the directory.

    The Clusters plug-in for Novell iManager 2.7.5 requires commons-lang-2.6.jar (or later version) of the class loader file. Novell iManager uses one class loader for all of its plug-ins. If multiple versions of the class loader file exist in the /var/opt/novell/iManager/nps/WEB-INF/lib directory, iManager loads whichever one comes first alphabetically. You must remove the earlier versions (such as commons-lang.jar or commons-lang-2.4.jar) to ensure that iManager loads the 2.6 or later version of the class loader file.

  6. Restart Tomcat by entering the following command, or reboot the server if a reboot is required by any of the patches applied.

    rcnovell-tomcat6 restart
    
  7. If you use Role-Based Services, continue with Section 5.7.4, Updating Role-Based Services for the Clusters Plug-In after Upgrading to OES 11 SP1.

5.7.4 Updating Role-Based Services for the Clusters Plug-In after Upgrading to OES 11 SP1

In OES 11 SP1 or later, the Clusters plug-in replaces the Clusters, the Cluster Manager, BCC Manager, Cluster Event Log, and Cluster Options menu options with the My Clusters and My Resources options. The plug-in is updated automatically to show new tasks, and hide old ones. However, the Role-Based Services role for Clusters is not updated automatically.

If you use Role-Based Services, you must reinstall the Clusters plug-in on the Role-Based Services Configuration page in order to pick up the modified menu options:

  1. In iManager, click Configuration, then select Role Based Services > RBS Configuration.

  2. Select the iManager 2.x Collections tab.

  3. On the iManager 2.x Collections page, view the entry for Role Based Services 2.novell.

    There are numbers in the columns for Modules, Installed, Out-of-Date, and Not-Installed.

  4. Click the number link in the Out-of-Date column for Role Based Services 2.novell.

  5. Select the check box next to Clusters, then click Update.

    This updates the RBS configuration information for the Clusters plug-in.

  6. Click OK to confirm the reinstallation.

  7. After the reinstallation is complete, click OK to confirm the success message.

  8. Log out of iManager.

  9. Restart Tomcat by entering the following command, or reboot the server if a reboot is required by any of the patches applied.

    rcnovell-tomcat6 restart
    
  10. Log in to iManager to use the updated Clusters plug-in.