Novell Vibe 3.2 Readme

November 14, 2011

1.0 Product Overview

Novell Vibe 3.2 offers many enhancements over prior Vibe versions for both Vibe users and administrators:

For Users

  • Landing Page Enhancements: Define background images and background colors, configure table column widths, and more.

  • Versioning Enhancements: Simultaneously delete multiple versions and configure versions to be automatically deleted after a certain number of days.

  • File Quotas: Set quotas for how big an individual file can be in a given folder.

  • Change Entry Type: Change an existing entry from one type to another type. For example, you can change an entry from a Blog view to a Discussion view after the entry is created.

  • Survey Enhancements: Modify the order that questions appear in a survey.

  • Workflow Enhancements: Transition a workflow based on field value, configure a workflow to modify the value of a field, and display an entry link in a workflow notification e-mail message.

  • Task Enhancements: Modify task dates directly from the task list, reorder tasks directly from the task list, and more.

For Administrators

  • Versioning Enhancements: Enable and disable versioning, set a maximum number of versions, enable or disable minor versioning, and more.

  • JMX Monitoring: Monitor applications, system objects, devices, and services through Java Management Extensions (JMX).

2.0 Vibe System Requirements

Novell Vibe 3.2 system requirements (including requirements for mobile devices that access the Vibe mobile interface) are listed in Vibe System Requirements in the Novell Vibe 3.2 Installation Guide.

3.0 Linux Installation Instructions

  1. Make sure that the Linux server where you plan to install Novell Vibe meets the system requirements.

  2. If a Web server is currently running on the Vibe server, stop it, and preferably disable it.

  3. Create or select a non-root Linux user and group that you want to own the Vibe directories and files and to run the Vibe software.

  4. Download the Vibe software to a temporary directory on your Linux server.

  5. In a terminal window, become root by entering su - and the root password.

  6. Change to the temporary directory where you downloaded the Vibe 3.2 tar file, then use the following command to untar the file:

    tar xvf novell-vibe-3.2.0.linux.tar

  7. In the directory where you downloaded and extracted the Vibe software, enter the following command to start the Vibe Installation program:


Complete installation instructions are available in the Novell Vibe 3.2 Installation Guide.

4.0 Windows Installation Instructions

  1. Make sure that the Windows server where you plan to install Novell Vibe meets the system requirements.

  2. Log in to the Windows server as a user with Administrator rights.

  3. If a Web server is currently running on the Vibe server, stop it, and preferably disable it.

  4. Download the Vibe software to a temporary directory on your Windows server.

  5. In Windows Explorer, browse to the directory where you downloaded and extracted the Vibe software, then double-click the installer-teaming.exe file to start the Vibe Installation program.

Complete installation instructions are available in the Novell Vibe 3.2 Installation Guide

5.0 Update Issues

5.1 Updating a Vibe 3.1 System

You can update from Vibe 3.1 to Vibe 3.2. For more information, see Updating From Novell Vibe 3.1 to Novell Vibe 3.2 in Update in the Novell Vibe 3.2 Installation Guide.

5.2 Updating a Vibe 3 System

To update a Vibe 3 system to Vibe 3.2, you must first update to Vibe 3.1 before you can update to Vibe 3.2. For information on how to update to Vibe 3.1, see “Update” in the Novell Vibe 3.1 Installation Guide.

5.3 Updating a Teaming 2.1 System

If you are upgrading from Teaming 2.1 or earlier, you must first update to Novell Vibe 3 before you can update to Vibe 3.1 and then 3.2. For information on how to update to Novell Vibe 3, see “Update” in the Novell Vibe 3 Installation Guide.

5.4 Incompatibility between Index Servers When Updating a High Availability System

When you update your high availability Vibe system to Vibe 3 or later from an earlier version, any deferred log records that currently exist become incompatible with each other.

To ensure that no incompatibility issues arise with deferred update logs during the update to Vibe 3 or later, you must clear all deferred update logs prior to upgrading.

For information on how to clear deferred update logs, see Performing Maintenance on a High Availability Lucene Index in the Novell Vibe 3.2 Administration Guide.

5.5 Caching Issues When Updating from Teaming 2.x to Vibe 3.x

If you have done performance tuning for your Vibe cache, you might experience caching issues after you update from a previous release to Vibe 3 or later, if you have modified either of the following configuration files:

  • ehcache-hibernate.xml (single-server Vibe environment)

  • ehcache-hibernate-clustered.xml (clustered Vibe environment)

You encounter issues only if you have modified either of the above files, because these files are overwritten during the Vibe update.

The issues you experience differ depending on whether you have a single-server Vibe environment, or whether you have a clustered Vibe environment.

If you have modified the ehcache-hibernate.xml file in order to optimize the caching performance for your single Vibe server, you might notice a decrease in caching performance after you update Vibe.

If you have modified the ehcache-hibernate-clustered.xml file in order to configure your clustered environment, you might notice that items that are added to the Vibe site are not always visible, or other erratic behavior. This is because information is not being cached and synchronized correctly across the various Vibe servers.

To resolve caching issues after an update:

  1. Modify the ehcache-hibernate.xml file or the ehcache-hibernate-clustered.xml file to reflect the file’s state before the Vibe update.

    The files are located in the following directories:




    c:\Program Files\Novell\Teaming\apache-tomcat\

    To see what these files looked like before the Vibe update, you can look in the backup directories in the following locations:




    c:\Program Files\Novell\Teaming\teaming-backup\

    IMPORTANT:Use these backup files only as a reference. Do not replace the entire ehcache-hibernate.xml file or ehcache-hibernate-clustered.xml file with the files in the backup directory. The new files contain important new settings that must be retained. You must manually add any customizations that existed in your old files.

  2. (Conditional) If you have a clustered Vibe environment and you need to modify the ehcache-hibernate-clustered.xml file, ensure that the values for the hostName, multicastGroupAddress, and multicastGroupPort properties are correct in the new ehcache-hibernate-clustered.xml file.

  3. Save any modifications that you made to the configuration files, then restart Vibe.

5.6 Issues When Updating from a Previous Vibe Release to Vibe 3.2

Resetting Definitions for the Vibe Site

When you update to Vibe 3.2 from a previous version, you should reset the definitions for your Vibe site if you want your folder and workspace definitions to no longer include the Branding element. This element is no longer useful and could be potentially confusing to users. Branding a folder or workspace is now done as described in Branding a Folder or Workspace in the Novell Vibe 3.2 Advanced User Guide.

For information on how to reset definitions in Vibe, see Resetting Your Definitions in Update in the Novell Vibe 3.2 Installation Guide.

Re-Indexing the Vibe Search Index

You should re-index the search index after you update to Vibe 3.2. For more information, see Resetting Your Definitions in Update in the Novell Vibe 3.2 Installation Guide.

5.7 Performance Issues after Updating to a New Version

After updating your Vibe system to a new version, you experience performance issues when you first navigate the Vibe system. This is because Vibe needs to compile the JSPs after an update.

These performance issues do not persist on subsequent visits to the Vibe site.

5.8 Cannot Reset Factory Workflow Definitions When Workflow Is in a Custom State

When resetting the workflow definitions to the factory default as described in Resetting Your Definitions in Update in the Novell Vibe 3.2 Installation Guide, you encounter a general error informing you to contact your system administrator if you have added a custom state to a factory workflow (such as the Task workflow) and there is currently an entry in the custom state.

If you are trying to reset multiple definitions simultaneously and the factory workflow fails to reset due to this issue, all definitions will fail to reset.

5.9 Manual Ehcache Configuration Settings Are Not Preserved on Update

If you manually edited the ehcache configuration settings by modifying the ehcache-hibernate-clustered.xml file on your Vibe server, the settings are not preserved when you update Vibe.

If you manually edited the ehcache-hibernate-clustered.xml file, you must complete the following after updating Vibe in order to preserve your settings:

  1. On your updated Vibe server, locate the ehcache-hibernate-clustered.xml file in the backup directory.




    c:\Program Files\Novell\Teaming\teaming-backup\
  2. Manually copy the custom information from your old ehcache-hibernate-clustered.xml file in the backup directory to the new ehcache-hibernate-clustered.xml file on the current Vibe server.




    c:\Program Files\Novell\Teaming\apache-tomcat\

    IMPORTANT:Do not replace the new ehcache-hibernate-clustered.xml file with your old ehcache-hibernate-clustered.xml file. Doing so overwrites important factory changes that were made to the ehcache-hibernate-clustered.xml file.

  3. Save and close the ehcache-hibernate-clustered.xml file that you modified on the current Vibe server.

  4. Stop and restart Vibe.

6.0 Installation Issues

6.1 The Vibe Server and the Lucene Server Must Use the Same JDK

If Vibe and the Lucene Index are running on separate servers, you must use the same JDK for both servers. Using different JDKs results in undesired behavior, such as not being able to create calendar entries.

6.2 Character Restrictions in Usernames and Passwords

Do not use extended characters or double-byte characters in Novell Vibe usernames and passwords. This includes usernames and passwords that are synchronized from an LDAP directory into Vibe.

This limitation is caused by the open source Spring Security that Vibe uses for authentication, in combination with the various authentication methods (both basic authentication and form-based authentication) used by single sign-on products such as Novell Authentication Manager, by Web services, and by WebDAV. Only ASCII characters are properly interpreted in all combinations.

6.3 Username Character Restrictions for LDAP Synchronization and Login

LDAP usernames that contain special characters ( / \ * ? " < > : | ) cannot be used as Novell Vibe usernames. If your LDAP directory includes usernames with these characters, they synchronize to the Vibe site, but the associated users cannot log in.

These characters cannot be used in a Vibe username because a Vibe username becomes the user’s workspace title, and the workspace title becomes an element of the hierarchical path that leads to the workspace. These characters are not legal characters in Linux and Windows pathnames.

6.4 Character Restrictions in the Software Installation Directory Name

Do not use extended characters or double-byte characters in the installation directory name for Novell Vibe file. The default location for the Vibe software is:




c:\Program Files\Novell\Teaming

6.5 Character Restrictions in the File Repository Directory Name

Do not use extended characters or double-byte characters in directory names in the path to the Novell Vibe file repository. The default location for the file repository root directory is:





The Oracle Outside In viewers that are used to render various file types into HTML for viewing in the Vibe site and for indexing do not handle directory names that include extended characters and double-byte characters.

6.6 Default Database Name

When you have the Novell Vibe installation program create the Vibe database for you, the database is given the name of sitescape. This database name is currently hard-coded into the database creation scripts used by the installation program. The name dates back to the name of the company that previously owned the Vibe software.

If you want the Vibe database to have a different name, you can edit the database creation script, then run the database creation script manually before you start the Vibe installation program. If you do this, you must also update the JDBC URL when you run the Vibe installation program. Prior to upgrading to a new version, the database update scripts also need to be modified.

IMPORTANT:Changing the Vibe database name is not recommended.

6.7 Restrictions on Applet Support

Applets are not supported on 64-bit Firefox on a system with a Java Runtime Environment (JRE) earlier than 1.6.0_12.

On a 64-bit operating system, updating to JRE or later enables the applets to work.

For example, multi-file drag-and-drop from the desktop, file paste from the desktop, Edit in Place, and the graphical display in the workflow editor do not work where applets are not supported.

6.8 Edit in Place Support for Mac Users

For Mac users, Vibe looks for in the following directory on users’ Mac workstations:


If your organization’s standard location for is in a different location on users’ workstations, you can reconfigure Vibe to look for in your preferred location.

  1. Change to the following directory:




    c:\Program Files\Novell\Teaming\apache-tomcat-version\
  2. Open the file in a text editor.

  3. Locate the block of lines that start with:
  4. Copy that set of lines to the clipboard of your text editor.

  5. Open the file, which is located in the same directory as the file.

  6. Paste the block of lines you copied at the end of the file.

  7. Edit the location of the software to reflect its location in your organization.

  8. Save and close the file.

  9. Close the file without saving it.

  10. Stop and restart Vibe to put the new software location into effect on your Vibe site.

6.9 NFS Support

NFS file system mounts are supported for placing the Vibe file repository on a remote server from where Vibe is running. However, NFS file system mounts are not supported for placing the Lucene index on a remote server from where the Lucene Index Server is running.

6.10 Firewall Issue on Windows Server 2008 R2

On Windows Server 2008 R2, the firewall is enabled by default and ports 80 and 443 are blocked. Vibe needs to use these ports, so Vibe needs to be an allowed program on your Windows server.

To prepare your Windows Server 2008 R2 machine for use with Vibe:

  1. In the Control Panel, double-click Windows Firewall.

  2. Click Allow a program through Windows Firewall.

  3. Open the ports that Vibe needs to use through the firewall:

    1. Click Add Port.

    2. In the Name field, specify a descriptive name for the HTTP port that Vibe uses for non-secure connections.

    3. In the Port field, specify 80.

    4. Click OK.

    5. Repeat Step 3.a through Step 3.d for the secure HTTP port of 443.

  4. After defining the two ports, click OK in the Windows Firewall Settings dialog box to allow Vibe to communicate through the firewall on these ports.

6.11 JDK Dependency for SSL Connections to WebDAV Servers

If you want to use an SSL connection between your Novell Vibe site and a WebDAV server, and if the WebDAV server has a self-signed certificate rather than a certificate provided by a certificate authority, you must use the Sun JDK. The existing Vibe functionality for handling self-signed certificates is not compatible with the way the IBM JDK handles self-signed certificates.

6.12 Updated Visual C++ Redistributable Package on Windows

Novell Vibe uses Oracle Outside In 8.3.2 viewer technology for displaying documents and images on the Vibe site and for indexing documents. This viewer technology relies on Support Pack 1 of the Microsoft Visual C++ 2005 Redistributable Package. If the Windows server where you install Vibe does not already have the latest version of the Visual C++ Redistributable Package installed, you must install it before your Vibe site can function properly. The required version of the Visual C++ Redistributable Package is available from:

For more information, see New Dependency for Outside In 8.2.0 and Newer Versions, Windows Products Only (Doc ID 468895.1) on the Oracle Support Web site. Oracle Support site login is required in order to access the support document.

6.13 Compatibility with Access Manager

To successfully use Novell Vibe with Novell Access Manager, Access Manager 3.1 SP1 IR1 is required. This version is available on the Novell Downloads Web site.

7.0 Vibe Issues

7.1 Cannot Perform Actions on Multiple Tasks Simultaneously

When you perform the following actions on multiple tasks in the task list, your changes are reverted when you refresh the page:

You can reorder tasks, make tasks sub-tasks, and make sub-tasks main tasks when you perform these actions one task at a time, as described in Reordering Tasks One Number at a Time, Making a Main Task a Sub-Task, and Making a Sub-Task a Main Task in the Novell Vibe 3.2 User Guide.

7.2 Saving a Vibe Document with OpenOffice on Linux Creates Two File Versions

When you edit a file in Vibe with OpenOffice on Linux, two new file versions are generated each time you save the file.

This issue is due to a bug in the way that OpenOffice communicates with WebDAV.

For more information about editing files in Vibe, see Viewing and Editing Files in Working with Folder Entries in the Novell Vibe 3.2 User Guide.

7.3 Link (URL) Element on a Landing Page Does Not Work With Internet Explorer

When you create a link from a landing page with the Link (URL) element, the link is not activated on the landing page unless you select the Open the URL in a new window option when configuring the element.

For more information about how to add this element to your landing page, see Adding Content to Your Landing Page in the Novell Vibe 3.2 Advanced User Guide.

7.4 Safari on Mac Does Not Allow RSS Feed Creation with the Add Bookmark Option

The Add Bookmark option that is available after you paste the RSS URL into the browser does not work when you use Safari on a Mac. Instead, you must use the Bookmark menu to create an RSS feed.

This is an issue with the way Safari deals with RSS feeds; it is not an issue with Vibe itself.

7.5 Adding Files with Drag and Drop Does Not Work on Mac

Because of Java limitations on the Mac, you cannot drag and drop files to add files to a folder or to attach files to an entry as described in Dragging and Dropping Files in Working with Folder Entries in the Novell Vibe 3.2 User Guide.

You can use the Vibe applet that is used for drag and drop if you copy the file that you want to add and paste it into the applet. However, dragging the file onto the applet does not work.

7.6 LDAP Synchronization Issues

Issues with Initial Synchronization of Vibe Users

If you create Novell Vibe users by importing users from an LDAP directory, all users in the LDAP directory might not appear in Vibe if the value of the LDAP attribute that you are using to synchronize users is not unique. For example, if you are using the cn attribute to identify users and if you have multiple users with the same cn value, only the first instance of the duplicate username is synchronized into Vibe.

To resolve this issue, use an attribute whose value is always unique across all containers, such as emailAddress.

Issues with Renaming and Moving Users in Your LDAP Directory

Renaming or moving users in your LDAP directory might result in new users being created in Vibe. This is because when you rename or move a user in the LDAP directory, Vibe assumes that the new name (or the new location of the same name) represents a new user, not a modified user, and creates a new Vibe user.

To resolve this issue, you should specify an LDAP attribute that uniquely identifies the user. For more information, see LDAP Attribute to Identify a User or Group in LDAP Connections in the Novell Vibe 3.2 Installation Guide.

7.7 Workspace Copy Limitation

When you copy a workspace, the custom form and workflow definitions in that workspace are not transferred to the copy of the workspace. You can work around this limitation by moving the definitions to a higher level in the workspace tree.

  1. Navigate to the folder in the original workspace where the definitions are located.

  2. On the Workspace toolbar, click Manage > Form and View Designers.

  3. Expand the Form and View Designers tree, then click the definition that you want to move.

  4. In the Definition Properties box, click Move This Definition to display the workspace and folder tree for your Vibe site, then expand the tree as needed to display an appropriate destination for the definition.

    To make the definition available in the copy of the original workspace, move the definition to a location in the tree that is above both the original workspace and the copy of the workspace.

    To make the definition available globally on your Vibe site, move it to the root of the workspace and folder tree.

  5. To move the definition, select the destination, then click OK.

  6. Click Close twice to return to the main Vibe page.

  7. Verify that the definition is now available in the copy of the workspace.

  8. Repeat this procedure for each definition that needs to be available in the copied workspace.

7.8 Export/Import Limitation

When an exported workspace, folder, or entry has a link to something that isn’t included in the export file, the link won’t work correctly when it is imported to a different Vibe system.

7.9 File Deletion Issue with MySQL

If you are using MySQL, you might see the following error when you upload files and then delete them:

class org.hibernate.exception.GenericJDBCException
Cannot release connection

This is related to a MySQL defect. To resolve the problem, update MySQL to version 5.1.40 or later.

7.10 Password-Protected Files

Files that have been password-protected in the application where they were created cannot be viewed on the Novell Vibe site. This is working as designed.

7.11 Mirrored Folder Issues

Mirrored Folder Structure Limitation

You cannot use the Novell Vibe Move This Folder feature to move one Mirrored File folder inside of another Mirrored File folder.

Mirrored Folder Versioning Limitation

If you edit a file in a mirrored folder and then check the version history, you see only the latest version of the file and only the latest version of the file is available for editing from the mirrored location. This is working as designed. Document versioning is not currently available in mirrored folders.

7.12 Folder and Workspace Nesting Issue

Because of database restrictions, the maximum number of nested folders and workspaces that Vibe allows is 45. For example, you can create a folder within a folder, then create a folder within that folder, and so forth, until the folder structure is 45 levels deep. You cannot exceed 45 levels in the folder structure.

7.13 License Report Issues

You can view current Novell Vibe license usage by clicking the Administration icon, then under Reports, clicking License Report. The License Report currently counts Administrator, Guest, and three internal users (_emailPostingAgent, _jobProcessingAgent, and _synchronizationAgent) as local users. Administrator counts as an active user, but the other four local users do not count against your Vibe license usage.

7.14 Date Attribute in Custom Entries and Views

If you use the Date attribute in a custom entry or view, users in different time zones might see a different date compared to what you see.

Novell Vibe stores the date as midnight on the selected date in the Vibe user’s time zone in GMT. So, for example, January 13, 2010 in the Mountain time zone is stored as GMT-7:00 (20100113T0700). No problem appears for people in the same time zone. However, for people in a different time zone, Mountain time zone midnight could be a different day in their time zone. This discrepancy will be resolved in an upcoming release.

7.15 Drag and Drop from a GroupWise Message

In the GroupWise client, you cannot drag a file that is attached to a GroupWise message and drop it successfully into the Novell Vibe drag-and-drop window that opens when you click Add file to folder on the Folder Entry toolbar. Save the attachment first, then drag and drop the saved file into the drag-and-drop window.

7.16 GroupWise Integration Issue

In order to access a Novell Vibe site from the GroupWise Windows client, the time setting on the GroupWise user’s workstation must match the time setting on the Vibe server within five minutes. If there is a discrepancy of more than five minutes, the GroupWise client’s attempt to contact the Vibe site times out. If possible, reset the time of the server or the workstation to the correct and matching time.

If the time difference is a necessary part of your system configuration, you can change the timeout setting for Web services such as GroupWise that authenticate to the Vibe site through WS-Security.

  1. Make a backup copy of the following file:


  2. Open the server-config.wsdd file in a text editor.

  3. Search for the following section:

    <handler type="">
    <parameter name="passwordCallbackClass"
    <parameter name="action" value="UsernameToken Timestamp"/>
  4. Insert a timeToLive parameter with large timeout value (for example, 86400 for 24 hours).

    <handler type="">
    <parameter name="passwordCallbackClass"
    <parameter name="action" value="UsernameToken Timestamp"/>
    <parameter name="timeToLive" value="86400"/>
  5. Repeat Step 3 and Step 4 for the second instance of the section in the server-config.wsdd file.

  6. Save the server-config.wsdd file, then restart the server.

This configuration change affects all client applications that authenticate to the server through WS-Security, not just GroupWise.

7.17 Firefox Limitation When Sending E-Mail

If you send an e-mail message from the Novell Vibe site, and you have a typographical error or invalid recipient in the Add E-Mail Addresses field, an error displays, along with a Return to Previous Page button. In Firefox, you return to the Send E-Mail page, but the message content is lost. In Internet Explorer, the message content is retained.

When you use Firefox to send e-mail from the Vibe site, select Vibe users as recipients whenever possible, or copy recipient e-mail addresses to avoid typographical errors in the Add E-Mail Addresses field.

7.18 WebDAV Issues

File Rename Issue When Using WebDAV

Renaming a Vibe file through a WebDAV client renames the attachment file only. It does not rename the title of the Vibe folder entry that the file is associated with.

This is because of the capability recently added to Vibe that allows you to specify any title of your choosing when creating a File entry, regardless of the filename of the associated file. Historically, the title for all File entries was the same as the filename of the associated file.

Windows Update for WebDAV Functionality for Windows Vista and Windows XP

IMPORTANT:Install this update only on Windows Vista and Windows XP. Do not install this update on Windows 7.

In order to use the Novell Vibe Edit in Place feature in your browser on Windows Vista and Windows XP, you must install the following Windows WebDAV update:

Software Update for Web Folders (KB907306).

This Windows update enables and Microsoft Office to interact correctly with the Vibe Edit in Place feature.

WebDAV/Edit in Place Issues with Microsoft Windows Vista and Microsoft Office

Microsoft Windows Vista has some issues with WebDAV access that affect all WebDAV interactions. In addition, a Vista-specific issue with applets can prevent the Novell Vibe Edit in Place feature from working properly. Be sure you are running the latest version of Vista. Be sure you have installed the Windows WebDAV update described in Windows Update for WebDAV Functionality for Windows Vista and Windows XP.

Windows Vista users who are using Internet Explorer might see a Java warning when they try to use Edit in Place. (Firefox users do not see this error.)

To configure Internet Explorer to support the Vibe Edit in Place feature:

  1. In Internet Explorer, click Tools > Internet Options.

  2. Click Security, select Trusted Sites, then click Sites.

  3. In the Add this website to the zone field, specify the URL of your Vibe server, then click Add.

  4. Select or deselect Require server verification (https:) for all sites in this zone as appropriate for your Vibe server.

  5. Click Close, then click OK to save the security settings.

To configure Windows Vista to support the Vibe Edit in Place feature in Microsoft Office, you must add new keys to the Windows registry for each Microsoft Office application.

  1. In Windows Explorer, navigate to Program Files/Microsoft Office/Office12.

  2. Scroll down to each Microsoft Office .exe in turn:

  3. Right-click each executable, then click Properties.

  4. Click Compatibility.

  5. Select Run this program in compatibility mode for, then select Windows XP (Service Pack 2) from the drop-down list.

  6. Reboot the computer.

You should now be able to use the Vibe Edit in Place feature with Microsoft Office files.

NOTE:Although these steps enable Edit in Place for Vibe, they do not fix Vista’s inability to attach via WebDAV in Vibe.

For additional information on applets, view the following Sun bulletins:

WebDAV/Edit in Place Issue on Windows 7

If you use the Novell Vibe Edit in Place feature to edit a Word document using Office 2007 or Office 2010 on a Windows 7 workstation, Word requests a location to save the edited file rather than saving it back to the Vibe site. Depending on whether you want to run Vibe with a secure HTTPS) or non-secure (HTTP) connection, this affects how you need to configure Vibe. For more information, see Editing Files with Edit-in-Place Functionality in Configuring Vibe to Support WebDAV on Windows 7 in the Novell Vibe 3.2 Administration Guide.

WebDAV URL Issue on Windows Vista and Windows 7

If you copy the WebDAV URL associated with a Novell Vibe folder and try to use the Add Network Location feature, Windows Vista and Windows 7 might not be able to map the drive. Instead, you should always use the Map Network Drive feature when using Vibe on Windows Vista and Windows 7.

WebDAV Limitations on Mac

When using WebDAV functionality in a Mac environment, you encounter various limitations.

Limitations When Editing Files on Mac through WebDAV

Edit-in-Place functionality is not supported on Mac when you use Microsoft Office as your document editor. To use Edit-in-Place functionality on Mac, you must use OpenOffice (or LibreOffice) as your document editor.

For more information, see Using WebDAV to Edit Individual Files in the Novell Vibe 3.2 Advanced User Guide.

Limitations When Viewing a Vibe Folder on Mac through WebDAV

Because of limitations with WebDAV on Mac, you cannot use WebDAV to view a Vibe folder in a Mac environment.

For more information, see Using WebDAV on a Vibe Folder in the Novell Vibe 3.2 Advanced User Guide.

7.19 Viewing a Vibe Folder through Windows Explorer Displays an Additional Folder on Windows XP

On Windows XP, when you view a Vibe folder through Windows Explorer, an additional sub-folder with the same name as the parent folder might be displayed.

To resolve this problem:

  1. Launch a Web browser.

  2. Navigate to the Microsoft Download Center and install the Software Update for Web Folders (KB907306)

  3. Follow the on-screen instructions to install the software update.

7.20 Data Quota Issue with creates a new document version each time you click Save, instead of creating one new version when you exit the edited document. This behavior can cause you to quickly meet your data quota. You can avoid creating unnecessary versions of the same document, and if you do create them, you can delete them.

Avoiding Unnecessary Document Version Creation

To avoid creating unnecessary versions of the same document, do either of the following:

  • Do not click Save multiple times when editing a document. Instead, click Save only once, before closing the document in

  • When you edit documents in Vibe, use a document editor other than, such as Microsoft Word.

Deleting Unnecessary Versions of a Document

You can delete specific versions of a file, as described in Deleting Existing Versions of a File in the Novell Vibe 3.2 User Guide.

7.21 HTML Conversion Error on a Linux Server

If you see an HTML Conversion Error when you try to view a file, your Vibe Linux server might be missing necessary libraries.

To install the missing libraries:

  1. Change to the following directory:

  2. Run the exporter program.

    The errors about missing input and output files are to be expected.

  3. Look for errors about missing libraries.

  4. If there are library errors, install any libraries that are missing.

7.22 The User Profile Does Not Support Custom JSP Files

When you create or modify attributes for the User Profile form and view in the Form and View Designers tool, you cannot reference custom JSP files.

This ability still exists for modifying attributes for workspaces, folders, and entries, as described in Enabling Vibe Forms and Views to Reference JSP Files in the Novell Vibe 3.2 Advanced User Guide.

7.23 Cannot Read the Latest File Version if Filenames Are Not the Same Case

With previous versions of Vibe that are installed on Linux, when you add a new version of an existing file, and the filenames for the current version and the new version do not have the same case (for example, test.odp and test.ODP), Vibe recognizes these as two different files in the database, and you cannot access the latest version of the file.

To fix this problem, simply rename the filename to match the case of the original filename.

In Vibe 3 and later, this issue does not exist if the original file was uploaded after the upgrade to Vibe 3. Filenames can be uploaded to the Vibe site with mismatching case (for example, test.odp and test.ODP) and the Vibe database recognizes them as the same file.

8.0 Database Issues

8.1 Log File Does Not Accurately Report Database Creation

The installer.log file sometimes reports that the Vibe database was created successfully when it actually wasn’t. Ensure that your database was created successfully.

The Vibe database is called sitescape.

For more information about the Vibe database, see Planning the Vibe Database in the Novell Vibe 3.2 Installation Guide.

9.0 Developer Issues

9.1 Multi-Reference Values in SOAP Payloads

By default, Novell Vibe SOAP payloads do not generate multi-reference values. You can change the server-config.wsdd files so that multi-reference values are generated.

  1. Change to the directory where a server-config.wsdd file is located.

    A Vibe installation includes two server-config.wsdd files. The default locations of these files vary by platform:




    c:\Program Files\Novell\Teaming\apache-tomcat-version\webapps\
    c:\Program Files\Novell\Teaming\apache-tomcat-version\webapps\
  2. In the following line:

    <parameter name="sendMultiRefs" value="false"/>

    change false to true.

  3. Save the server-config.wsdd file, then exit the text editor.

  4. Create a backup copy of the modified server-config.wsdd file.

    If you update the Vibe software, the server-config.wsdd file is overwritten by the Vibe Installation program. You must either restore the updated file after the update or repeat the modification.

  5. Repeat the procedure for the second server-config.wsdd file in the Vibe software.

10.0 Localization Issues

10.1 Extended Characters Are Not Allowed in Simple URLs

On the Configure Default Settings page of your workspace, the Define URL field does not accept extended characters. Use only alphabetic characters and numbers in simple URLs.

10.2 Extended and Double-Byte Characters in Attachment Filenames

If Outlook users send postings to the Novell Vibe site and if the messages have attachments with extended or double-byte characters in the filenames, the attachment does not arrive on the Vibe site unless the Exchange server is properly configured. To configure the Exchange server to pass the filenames correctly, follow the instructions in Foreign Characters Appear as Question Marks When Sent from OWA.

10.3 Filenames That Contain Extended and Double-Byte Characters Are Changed When Creating a ZIP File

When Vibe 3 or later is used to create a ZIP file with files that contain double-byte characters in the filename, the filenames for the downloaded files are displayed as _file1, _file2, _file3, etc. This is because the Java ZIP file facility is not capable of creating filenames that contain double-byte characters.

The files within Vibe remain unchanged.

This is due to a problem in the way Java handles non-ASCII characters. For information on how you can modify the way Vibe deals with .zip files that are downloaded that contain extended or double-byte characters in the filename, see Enabling ZIP Files That Contain Extended or Double-Byte Characters in the Filename to Be Downloaded in the Novell Vibe 3.2 Administration Guide.

For information on how to download files in Vibe, see Downloading Files in the Novell Vibe 3.2 User Guide.

10.4 Chinese Characters in Activity Logs

When a report.csv file for an activity report is opened in Microsoft Excel, Chinese characters do not display correctly, even though the report.csv file has been created correctly, because Excel always reads the file using the ISO Latin character set.

One workaround is to use the Calc spreadsheet program instead of Excel. It displays Chinese characters correctly.

As a workaround in Excel:

  1. Import the report.csv file into Excel by using Data > Import External Data > Import Data.

  2. Select the report.csv file, then click Open.

  3. Select Delimited, select UTF-8, then click Next.

  4. Select Comma as the delimiter, click Next, then click Finish.

Excel should now display the Chinese characters correctly.

10.5 Internet Explorer 6 Limitation with International Characters in Filenames

In Internet Explorer 6, if you upload a file whose filename includes international characters into a File folder, and if you edit that file and create a new version, the link to the original version of the file no longer works, because Internet Explorer 6 double-encoded the filename. To resolve this issue, update to Internet Explorer 7 or later.

11.0 Security Issues

To ensure that your Novell Vibe site is adequately secure, keep your operating system updated with all patches and security fixes.

12.0 Vibe 3.2 Bug Fixes

For a list of the bugs that have been fixed since Vibe 3.1, see Novell Vibe 3.2 Bug List. You can look up the bug numbers in Bugzilla for more information about each bug.

13.0 Vibe 3.1 Bug Fixes

For a list of the bugs that have been fixed since Vibe 3, see the Novell Vibe 3.1 Bug List. You can look up the bug numbers in Bugzilla for more information about each bug.

14.0 Vibe Documentation

The following sources provide information about Novell Vibe 3.2:

  • Online product documentation: Novell Vibe 3.2 Documentation Web site

  • Product documentation included within Novell Vibe. Click the Help icon (question mark) in the upper right corner of the Vibe Home page.

In addition to the Novell Vibe product documentation, the following resources provide additional information about Vibe 3.2: