Novell Vibe 3.4 Readme

June 2014

1.0 Product Overview

To help you maximize your Vibe investment, Novell Vibe 3.4 includes licensing changes related to external users.

These licensing changes are important not only because they allow you to expose your Vibe site to users outside of your organization at no additional cost, but because future versions of the Vibe software will provide enhanced tools for sharing information with external users.

There are some restrictions, so refer to the EULA for more information.

Novell Vibe 3.4 also includes enhanced mobile device support for the Vibe mobile app, as well as various bug fixes.

2.0 Vibe System Requirements

Novell Vibe 3.4 system requirements (including requirements for mobile devices that access the Vibe mobile interface) are listed in Vibe System Requirements in the Novell Vibe 3.4 Installation Guide.

3.0 Linux Installation Instructions

  1. Make sure that the Linux server where you plan to install Novell Vibe meets the system requirements.

  2. If a Web server is currently running on the Vibe server, stop it, and preferably disable it.

  3. Create or select a non-root Linux user and group that you want to own the Vibe directories and files and to run the Vibe software.

  4. Download the Vibe software to a temporary directory on your Linux server. The Vibe software is available to download at the Novell Download Site.

  5. In a terminal window, become root by entering su - and the root password.

  6. Change to the temporary directory where you downloaded the Vibe 3.4 tar file, then use the following command to untar the file:

    tar xvf novell-vibe-3.4.0.linux.tar

  7. In the directory where you downloaded and extracted the Vibe software, enter the following command to start the Vibe Installation program:

    ./installer-teaming.linux

Complete installation instructions are available in the Novell Vibe 3.4 Installation Guide.

4.0 Windows Installation Instructions

  1. Make sure that the Windows server where you plan to install Novell Vibe meets the system requirements.

  2. Log in to the Windows server as a user with Administrator rights.

  3. If a Web server is currently running on the Vibe server, stop it, and preferably disable it.

  4. Download the Vibe software to a temporary directory on your Windows server. The Vibe software is available to download at the Novell Download Site.

  5. In Windows Explorer, browse to the directory where you downloaded and extracted the Vibe software, then double-click the installer-teaming.exe file to start the Vibe Installation program.

Complete installation instructions are available in the Novell Vibe 3.4 Installation Guide

5.0 Update Issues

5.1 Updating a Vibe 3.x System

You can update from Vibe 3, Vibe 3.1, or Vibe 3.2 to Vibe 3.3. To update to Vibe 3.4, you must first update to Vibe 3.3. You need to update the database separately from the software. For more information, see Update in the Novell Vibe 3.4 Installation Guide.

5.2 Updating a Teaming 2.1 System

If you are upgrading from Teaming 2.1 or earlier, you must first update to Novell Vibe 3 before you can update to Vibe 3.3, and then to Vibe 3.4. For information on how to update to Novell Vibe 3, see “Update” in the Novell Vibe 3 Installation Guide.

5.3 Re-Indexing the Vibe Search Index

Because of an issue that was addressed regarding attachment file sizes, you should re-index the search index after you update to Vibe 3.3 in order for attachment sizes to be displayed correctly. For more information on how to re-index the search index, see Resetting Your Definitions in Update in the Novell Vibe 3.4 Installation Guide.

5.4 Incompatibility between Index Servers When Updating a High Availability System

When you update your high availability Vibe system to Vibe 3 or later from an earlier version, any deferred log records that currently exist become incompatible with each other.

To ensure that no incompatibility issues arise with deferred update logs during the update to Vibe 3 or later, you must clear all deferred update logs prior to upgrading.

For information on how to clear deferred update logs, see Performing Maintenance on a High Availability Lucene Index in the Novell Vibe 3.4 Administration Guide.

5.5 Manual Ehcache Configuration Settings Are Not Preserved on Update

If you have done performance tuning for your Vibe cache, you might experience caching issues after you update from a previous release to Vibe 3 or later, if you have modified either of the following configuration files:

  • ehcache-hibernate.xml (single-server Vibe environment)

  • ehcache-hibernate-clustered.xml (clustered Vibe environment)

You encounter issues only if you have modified either of the above files, because these files are overwritten during the Vibe update.

The issues you experience differ depending on whether you have a single-server Vibe environment, or whether you have a clustered Vibe environment.

If you have modified the ehcache-hibernate.xml file in order to optimize the caching performance for your single Vibe server, you might notice a decrease in caching performance after you update Vibe.

If you have modified the ehcache-hibernate-clustered.xml file in order to configure your clustered environment, you might notice that items that are added to the Vibe site are not always visible, or other erratic behavior. This is because information is not being cached and synchronized correctly across the various Vibe servers.

To resolve caching issues after an update:

  1. Modify the ehcache-hibernate.xml file or the ehcache-hibernate-clustered.xml file to reflect the file’s state before the Vibe update.

    The files are located in the following directories:

    Linux:

    /opt/novell/teaming/apache-tomcat/
                               webapps/ssf/WEB-INF/classes/config
    

    Windows:

    c:\Program Files\Novell\Teaming\apache-tomcat\
                               webapps\ssf\WEB-INF\classes\config
    

    To see what these files looked like before the Vibe update, you can look in the backup directories in the following locations:

    Linux:

    /opt/novell/teaming/teaming-backup/
                              ssf/WEB-INF/classes/config
    

    Windows:

    c:\Program Files\Novell\Teaming\teaming-backup\
                              ssf\WEB-INF\classes\config
    

    IMPORTANT:Use these backup files only as a reference. Do not replace the entire ehcache-hibernate.xml file or ehcache-hibernate-clustered.xml file with the files in the backup directory. The new files contain important new settings that must be retained. You must manually add any customizations that existed in your old files.

  2. (Conditional) If you have a clustered Vibe environment and you need to modify the ehcache-hibernate-clustered.xml file, ensure that the values for the hostName, multicastGroupAddress, and multicastGroupPort properties are correct in the new ehcache-hibernate-clustered.xml file.

  3. Save any modifications that you made to the configuration files, then restart Vibe.

5.6 Issues When Updating from a Previous Vibe Release to Vibe 3.3

5.6.1 Resetting Definitions for the Vibe Site

When you update to Vibe 3.3 from a previous version, you should reset the definitions for your Vibe site if you want your folder and workspace definitions to no longer include the Branding element. This element is no longer useful and could be potentially confusing to users. Branding a folder or workspace is now done as described in Branding a Folder or Workspace in the Novell Vibe 3.4 Advanced User Guide.

For information on how to reset definitions in Vibe, see Resetting Your Definitions in Update in the Novell Vibe 3.4 Installation Guide.

5.6.2 Re-Indexing the Vibe Search Index

You should re-index the search index after you update to Vibe 3.3. For more information, see Resetting Your Definitions in Update in the Novell Vibe 3.4 Installation Guide.

5.7 Performance Issues after Updating to a New Version

After updating your Vibe system to a new version, you experience performance issues when you first navigate the Vibe system. This is because Vibe needs to compile the JSPs after an update.

These performance issues do not persist on subsequent visits to the Vibe site.

5.8 Cannot Reset Factory Workflow Definitions When a Workflow Is in a Custom State

When you reset the workflow definitions to the factory default as described in Resetting Your Definitions in Update in the Novell Vibe 3.4 Installation Guide, you encounter a general error informing you to contact your system administrator if you have added a custom state to a factory workflow (such as the Task workflow) and there is currently an entry in the custom state.

If you are trying to reset multiple definitions simultaneously and the factory workflow fails to reset because of this issue, all definitions fail to reset.

6.0 Installation Issues

6.1 The Vibe Server and the Lucene Server Must Use the Same JDK

If Vibe and the Lucene Index are running on separate servers, you must use the same JDK for both servers. Using different JDKs results in undesired behavior, such as not being able to create calendar entries.

6.2 Character Restrictions in Usernames and Passwords

Do not use extended characters or double-byte characters in Novell Vibe usernames and passwords. This includes usernames and passwords that are synchronized from an LDAP directory into Vibe.

This limitation is caused by the open source Spring Security that Vibe uses for authentication, in combination with the various authentication methods—both basic authentication and form-based authentication—used by single sign-on products such as Novell Authentication Manager, by Web services, and by WebDAV. Only ASCII characters are properly interpreted in all combinations.

6.3 Username Character Restrictions for LDAP Synchronization and Login

LDAP usernames that contain special characters ( / \ * ? " < > : | ‘ ) cannot be used as Novell Vibe usernames. If your LDAP directory includes usernames with these characters, they synchronize to the Vibe site, but the associated users cannot log in.

These characters cannot be used in a Vibe username because a Vibe username becomes the user’s workspace title, and the workspace title becomes an element of the hierarchical path that leads to the workspace. These characters are not legal characters in Linux and Windows pathnames.

6.4 Character Restrictions in the Software Installation Directory Name

Do not use extended characters or double-byte characters in the installation directory name for Novell Vibe. The default location for the Vibe software is:

Linux:

/opt/novell/teaming

Windows:

c:\Program Files\Novell\Teaming

6.5 Character Restrictions in the File Repository Directory Name

Do not use extended characters or double-byte characters in directory names in the path to the Novell Vibe file repository. The default location for the file repository root directory is:

Linux:

/var/opt/novell/teaming

Windows:

c:\Novell\Teaming

The Oracle Outside In viewers that are used to render various file types into HTML for viewing in the Vibe site and for indexing do not handle directory names that include extended characters and double-byte characters.

6.6 Default Database Name

When you have the Novell Vibe installation program create the Vibe database for you, the database is given the name of sitescape. This database name is currently hard-coded into the database creation scripts used by the installation program. The name dates back to the name of the company that previously owned the Vibe software.

If you want the Vibe database to have a different name, you can edit the database creation script, then run the database creation script manually before you start the Vibe installation program. If you do this, you must also update the JDBC URL when you run the Vibe installation program. Prior to upgrading to a new version, the database update scripts also need to be modified.

IMPORTANT:Changing the Vibe database name is not recommended.

6.7 Restrictions on Applet Support

Applets are not supported on 64-bit Firefox on a system with a Java Runtime Environment (JRE) earlier than 1.6.0_12.

On a 64-bit operating system, updating to JRE 1.6.0.12 or later enables the applets to work.

For example, multi-file drag-and-drop from the desktop, file paste from the desktop, Edit in Place, and the graphical display in the workflow editor do not work where applets are not supported.

6.8 Edit in Place Support for Mac Users

For Mac users, Vibe looks for OpenOffice.org in the following directory on users’ Mac workstations:

/Applications/OpenOffice.org.app

If your organization’s standard location for OpenOffice.org is in a different location on users’ workstations, you can reconfigure Vibe to look for OpenOffice.org in your preferred location.

  1. Change to the following directory:

    Linux:

    /opt/novell/teaming/apache-tomcat-version/
                               webapps/ssf/WEB-INF/classes/config
    

    Windows:

    c:\Program Files\Novell\Teaming\apache-tomcat-version\
                               webapps\ssf\WEB-INF\classes\config
    
  2. Open the ssf.properties file in a text editor.

  3. Locate the block of lines that start with:

    edit.in.place.mac.editor
    
  4. Copy that set of lines to the clipboard of your text editor.

  5. Open the ssf-ext.properties file, which is located in the same directory as the ssf.properties file.

  6. Paste the block of lines you copied at the end of the ssf-ext.properties file.

  7. Edit the location of the OpenOffice.org software to reflect its location in your organization.

  8. Save and close the ssf-ext.properties file.

  9. Close the ssf.properties file without saving it.

  10. Stop and restart Vibe to put the new software location into effect on your Vibe site.

6.9 NFS Support

NFS file system mounts are supported for placing the Vibe file repository on a remote server from where Vibe is running. However, NFS file system mounts are not supported for placing the Lucene index on a remote server from where the Lucene Index Server is running.

6.10 Firewall Issue on Windows Server 2008 R2

On Windows Server 2008 R2, the firewall is enabled by default and ports 80 and 443 are blocked. Vibe needs to use these ports, so Vibe needs to be an allowed program on your Windows server.

To prepare your Windows Server 2008 R2 machine for use with Vibe:

  1. In the Control Panel, double-click Windows Firewall.

  2. Click Allow a program through Windows Firewall.

  3. Open the ports that Vibe needs to use through the firewall:

    1. Click Add Port.

    2. In the Name field, specify a descriptive name for the HTTP port that Vibe uses for non-secure connections.

    3. In the Port field, specify 80.

    4. Click OK.

    5. Repeat Step 3.a through Step 3.d for the secure HTTP port of 443.

  4. After defining the two ports, click OK in the Windows Firewall Settings dialog box to allow Vibe to communicate through the firewall on these ports.

6.11 JDK Dependency for SSL Connections to WebDAV Servers

If you want to use an SSL connection between your Novell Vibe site and a WebDAV server, and if the WebDAV server has a self-signed certificate rather than a certificate provided by a certificate authority, you must use the Sun JDK. The existing Vibe functionality for handling self-signed certificates is not compatible with the way the IBM JDK handles self-signed certificates.

6.12 Updated Visual C++ Redistributable Package on Windows

Novell Vibe uses Oracle Outside In 8.3.5 viewer technology for displaying documents and images on the Vibe site and for indexing documents. This viewer technology relies on Support Pack 1 of the Microsoft Visual C++ 2005 Redistributable Package. If the Windows server where you install Vibe does not already have the latest version of the Visual C++ Redistributable Package installed, you must install it before your Vibe site can function properly. The required version of the Visual C++ Redistributable Package is available from:

For more information, see New Dependency for Outside In 8.2.0 and Newer Versions, Windows Products Only (Doc ID 468895.1) on the Oracle Support Web site. Oracle Support site login is required in order to access the support document.

6.13 Compatibility with Access Manager

To successfully use Novell Vibe with Novell Access Manager, Access Manager 3.1 SP1 IR1 is required. This version is available on the Novell Downloads Web site.

7.0 Vibe Issues

7.1 Do Not Delete System User Accounts

There are four system user accounts in Vibe. You should not delete any of these accounts, because doing so can cause issues with your Vibe system. The system accounts are: Admin, E-mail Posting Agent, Synchronization Agent, and Guest.

If you do need to delete any of these user accounts, first consult with Novell Support.

7.2 Do Not Delete a Vibe Zone

If you have a Vibe zone that you no longer need, you should not delete it. Deleting zones in Vibe can cause significant issues with your Vibe site.

If you do need to delete a Vibe zone, first consult with Novell Support.

7.3 Moving a Main Task Results in the Sub-Task Hierarchy to Be Lost

If you move a main (parent) task to another location on the Vibe site, all sub-tasks beneath that main task--even sub-tasks of sub-tasks (nested tasks)--all become main tasks within the original Tasks folder.

7.4 Saving a Vibe Document with OpenOffice on Linux Creates Two File Versions

When you edit a file in Vibe with OpenOffice on Linux, two new file versions are generated each time you save the file.

This issue is because of a bug in the way that OpenOffice communicates with WebDAV.

To resolve this issue, use the latest version of LibreOffice.

For more information about editing files in Vibe, see Viewing Files in Read-Only Mode in Working with Folder Entries in the Novell Vibe 3.4 User Guide.

7.5 Safari on Mac Does Not Allow RSS Feed Creation with the Add Bookmark Option

The Add Bookmark option that is available after you paste the RSS URL into the browser does not work when you use Safari on a Mac. Instead, you must use the Bookmark menu to create an RSS feed.

This is an issue with the way Safari deals with RSS feeds. It is not an issue with Vibe itself.

7.6 Adding Files with Drag and Drop Does Not Work on Mac

Because of Java limitations on the Mac, you cannot drag and drop files to add files to a folder or to attach files to an entry as described in Dragging and Dropping Files in Working with Folder Entries in the Novell Vibe 3.4 User Guide.

You can use the Vibe applet that is used for drag and drop if you copy the file that you want to add and paste it into the applet. However, dragging the file onto the applet does not work.

7.7 Edit-in-Place and File Upload Applets Fail When Using Safari 7.x with OS X 10.9.x

When accessing Vibe with Safari 7.x and OS X 10.9.x, using the Edit-in-Place applet to edit a file (as described in Editing Files in the Novell Vibe 3.4 User Guide) and the File Upload applet (as described in Dragging and Dropping Files in the Novell Vibe 3.4 User Guide) results in an error and you are not able to edit or upload the file.

To configure Safari 7.x and OS X 10.9.x to support the Vibe Edit-in-Place feature and to support adding files to folders when using a browser that does not support HTML 5:

  1. With the Vibe site open, in Safari, click Menu > Preferences.

  2. Click the Security tab, then click Manage Website Settings.

  3. Select Java, then in the click the drop-down arrow next to the Vibe site URL and select Run in Unsafe Mode.

  4. Click Done.

7.8 Edit-in-Place and Other Applets No Longer Work on Chrome

The ability to edit documents in place (as described in Editing Files in the Novell Vibe 3.4 User Guide) and other Vibe applets no longer work on Chrome version 35 and later.

Other Vibe applets include the workflow graphical designer, and the dragging and dropping of files in the following circumstances:

  • When clicking Add Files in older browsers that do not support HTML 5

  • When pressing the Ctrl key when clicking Add Files in any browser (this invokes the file upload applet rather than leveraging HTML 5 to do the upload)

7.9 File Note Is Not Always Displayed on Oldest Version of a File

When a file contains multiple versions and a user attempts to add a note about the oldest version (Adding a Note about a File or File Version in the Novell Vibe 3.4 User Guide), the note is not always displayed.

7.10 LDAP Synchronization Issues

7.10.1 Issues When Deleting Users through LDAP

Novell recommends that you never select the option Delete Users That Are Not in LDAP when configuring your LDAP synchronization. This feature will either be enhanced or removed in future Vibe releases. User accounts that are deleted cannot be recovered. As a best practice, leave this LDAP option unchecked. Doing so disables users rather than deleting them.

7.10.2 Issues with Initial Synchronization of Vibe Users

If you create Novell Vibe users by importing users from an LDAP directory, all users in the LDAP directory might not appear in Vibe if the value of the LDAP attribute that you are using to synchronize users is not unique. For example, if you are using the cn attribute to identify users and if you have multiple users with the same cn value, only the first instance of the duplicate username is synchronized into Vibe.

To resolve this issue, use an attribute whose value is always unique across all containers, such as emailAddress.

7.10.3 Issues with Renaming and Moving Users in Your LDAP Directory

In order to rename or move users in your LDAP directory, ensure that you have specified a value for the setting LDAP attribute that uniquely identifies a user or group, as described in LDAP Attribute to Identify a User or Group in Gathering Directory Services Information in the Novell Vibe 3.4 Installation Guide. If a value is not specified for this setting, renaming or moving users in your LDAP directory might result in new users being created in Vibe.

7.11 Landing Page Issues

7.11.1 Link (URL) Element on a Landing Page Does Not Work With Internet Explorer

When you create a link from a landing page with the Link (URL) element, the link is not activated on the landing page unless you select the Open the URL in a new window option when configuring the element.

For more information about how to add this element to your landing page, see Adding Content to Your Landing Page in the Novell Vibe 3.4 Advanced User Guide.

7.11.2 Display Full Entry Option in the Enhanced View Element Can Display Incorrectly

In Vibe 3.3, the Display Full Entry option for the Enhanced View element was modified. If you added this option to a landing page in a previous release and you upgrade to Vibe 3.3, the option is automatically removed when you edit your landing page and then click OK. If you edit the landing page and then click Cancel, the element becomes unusable on the landing page.

7.12 Workspace Copy Limitation

When you copy a workspace, the custom form and workflow definitions in that workspace are not transferred to the copy of the workspace. You can work around this limitation by moving the definitions to a higher level in the workspace tree.

  1. Navigate to the folder in the original workspace where the definitions are located.

  2. On the Workspace toolbar, click Manage > Form and View Designers.

  3. Expand the Form and View Designers tree, then click the definition that you want to move.

  4. In the Definition Properties box, click Move This Definition to display the workspace and folder tree for your Vibe site, then expand the tree as needed to display an appropriate destination for the definition.

    To make the definition available in the copy of the original workspace, move the definition to a location in the tree that is above both the original workspace and the copy of the workspace.

    To make the definition available globally on your Vibe site, move it to the root of the workspace and folder tree.

  5. To move the definition, select the destination, then click OK.

  6. Click Close twice to return to the main Vibe page.

  7. Verify that the definition is now available in the copy of the workspace.

  8. Repeat this procedure for each definition that needs to be available in the copied workspace.

7.13 Export/Import Limitation

When an exported workspace, folder, or entry has a link to something that isn’t included in the export file, the link doesn’t work correctly when it is imported to a different Vibe system.

7.14 File Deletion Issue with MySQL

If you are using MySQL, you might see the following error when you upload files and then delete them:

class org.hibernate.exception.GenericJDBCException
Cannot release connection

This is related to a MySQL defect. To resolve the problem, update MySQL to version 5.1.40 or later.

7.15 Password-Protected Files

Files that have been password-protected in the application where they were created cannot be viewed on the Novell Vibe site. This is working as designed.

7.16 Mirrored Folder Issues

7.16.1 Mirrored Folder Structure Limitation

You cannot use the Novell Vibe Move This Folder feature to move one Mirrored File folder inside of another Mirrored File folder.

7.16.2 Mirrored Folder Versioning Limitation

If you edit a file in a mirrored folder and then check the version history, you see only the latest version of the file and only the latest version of the file is available for editing from the mirrored location. This is working as designed. Document versioning is not currently available in mirrored folders.

7.17 Folder and Workspace Nesting Issue

Because of database restrictions, the maximum number of nested folders and workspaces that Vibe allows is 45. For example, you can create a folder within a folder, then create a folder within that folder, and so forth, until the folder structure is 45 levels deep. You cannot exceed 45 levels in the folder structure.

7.18 License Report Issues

You can view current Novell Vibe license usage by clicking the Administration icon, then under Reports, clicking License Report. The License Report currently counts Administrator, Guest, and three internal users (_emailPostingAgent, _jobProcessingAgent, and _synchronizationAgent) as local users. The Administrator counts as an active user, but the other four local users do not count against your Vibe license usage.

7.19 Date Attribute in Custom Entries and Views

If you use the Date attribute in a custom entry or view, users in different time zones might see a different date than you see.

Novell Vibe stores the date as midnight on the selected date in the Vibe user’s time zone in GMT. For example, January 13, 2010 in the Mountain time zone is stored as GMT-7:00 (20100113T0700). No problem appears for people in the same time zone. However, for people in a different time zone, Mountain time zone midnight could be a different day in their time zone. This discrepancy will be resolved in an upcoming release.

7.20 GroupWise Integration Issues

7.20.1 Drag and Drop from a GroupWise Message

In the GroupWise client, you cannot drag a file that is attached to a GroupWise message and drop it successfully into the Novell Vibe drag-and-drop window that opens when you click Add file to folder on the Folder Entry toolbar. Save the attachment first, then drag and drop the saved file into the drag-and-drop window.

7.20.2 Cannot Access the Vibe Site from the GroupWise Windows Client

In order to access a Novell Vibe site from the GroupWise Windows client, the time setting on the GroupWise user’s workstation must match the time setting on the Vibe server within five minutes. If there is a discrepancy of more than five minutes, the GroupWise client’s attempt to contact the Vibe site times out. If possible, reset the time of the server or the workstation to the correct and matching time.

If the time difference is a necessary part of your system configuration, you can change the timeout setting for Web services such as GroupWise that authenticate to the Vibe site through WS-Security.

  1. Make a backup copy of the following file:

    teaming_directory/webapps/ssf/WEB-INF/server-config.wsdd

  2. Open the server-config.wsdd file in a text editor.

  3. Search for the following section:

    <handler type="java:org.apache.ws.axis.security.WSDoAllReceiver">
    <parameter name="passwordCallbackClass"
    value="org.kablink.teaming.remoting.ws.security.PWCallback"/>
    <parameter name="action" value="UsernameToken Timestamp"/>
    </handler>
    
  4. Insert a timeToLive parameter with large timeout value (for example, 86400 for 24 hours).

    <handler type="java:org.apache.ws.axis.security.WSDoAllReceiver">
    <parameter name="passwordCallbackClass"
    value="org.kablink.teaming.remoting.ws.security.PWCallback"/>
    <parameter name="action" value="UsernameToken Timestamp"/>
    <parameter name="timeToLive" value="86400"/>
    </handler>
    
  5. Repeat Step 3 and Step 4 for the second instance of the section in the server-config.wsdd file.

  6. Save the server-config.wsdd file, then restart the server.

This configuration change affects all client applications that authenticate to the server through WS-Security, not just GroupWise.

7.21 Cannot Communicate with an External Outbound Mail System

If you cannot get your Vibe site to communicate with an external outbound mail system (such as Novell GroupWise), you might need to configure the Vibe outbound e-mail server with TLS over SMTP. If your e-mail application requires this type of configuration, you can configure Vibe with TLS over SMTP by using STARTTLS, as described in Configuring Outbound E-Mail with TLS over SMTP in Managing E-Mail Configuration in the Novell Vibe 3.4 Administration Guide.

7.22 Vibe Tasks Are Displayed in Outlook as Calendar Events

When Vibe sends tasks to Outlook via an iCal attachment, the tasks appear as calendar events rather than as task items.

This is because of an issue with the way Outlook handles iCal events.

For more information about how Vibe uses iCal attachments to send calendar events and task items, see Synchronizing Tasks and Calendars to a Desktop Application in the Novell Vibe 3.4 Advanced User Guide.

7.23 Firefox Limitation When Sending E-Mail

If you send an e-mail message from the Novell Vibe site, and you have a typographical error or invalid recipient in the Add E-Mail Addresses field, an error displays, along with a Return to Previous Page button. In Firefox, you return to the Send E-Mail page, but the message content is lost. In Internet Explorer, the message content is retained.

When you use Firefox to send e-mail from the Vibe site, select Vibe users as recipients whenever possible, or copy recipient e-mail addresses to avoid typographical errors in the Add E-Mail Addresses field.

7.24 WebDAV Issues

7.24.1 File Rename Issue When Using WebDAV

Renaming a Vibe file through a WebDAV client renames the attachment file only. It does not rename the title of the Vibe folder entry that the file is associated with.

This is because of the capability recently added to Vibe that allows you to specify any title of your choosing when creating a File entry, regardless of the filename of the associated file. Historically, the title for all File entries was the same as the filename of the associated file.

7.24.2 Windows Update for WebDAV Functionality for Windows Vista and Windows XP

IMPORTANT:Install this update only on Windows Vista and Windows XP. Do not install this update on Windows 7.

In order to use the Novell Vibe Edit in Place feature in your browser on Windows Vista and Windows XP, you must install the following Windows WebDAV update:

Software Update for Web Folders (KB907306).

This Windows update enables OpenOffice.org and Microsoft Office to interact correctly with the Vibe Edit in Place feature.

7.24.3 WebDAV/Edit in Place Issues with Microsoft Windows Vista and Microsoft Office

Microsoft Windows Vista has some issues with WebDAV access that affect all WebDAV interactions. In addition, a Vista-specific issue with applets can prevent the Novell Vibe Edit in Place feature from working properly. Be sure you are running the latest version of Vista. Be sure you have installed the Windows WebDAV update described in Section 7.24.2, Windows Update for WebDAV Functionality for Windows Vista and Windows XP.

Windows Vista users who are using Internet Explorer might see a Java warning when they try to use Edit in Place. (Firefox users do not see this error.)

To configure Internet Explorer to support the Vibe Edit in Place feature:

  1. In Internet Explorer, click Tools > Internet Options.

  2. Click Security, select Trusted Sites, then click Sites.

  3. In the Add this website to the zone field, specify the URL of your Vibe server, then click Add.

  4. Select or deselect Require server verification (https:) for all sites in this zone as appropriate for your Vibe server.

  5. Click Close, then click OK to save the security settings.

To configure Windows Vista to support the Vibe Edit in Place feature in Microsoft Office, you must add new keys to the Windows registry for each Microsoft Office application.

  1. In Windows Explorer, navigate to Program Files/Microsoft Office/Office12.

  2. Scroll down to each Microsoft Office .exe in turn:

    excel.exe
    powerpnt.exe
    winword.exe
    ...
    
  3. Right-click each executable, then click Properties.

  4. Click Compatibility.

  5. Select Run this program in compatibility mode for, then select Windows XP (Service Pack 2) from the drop-down list.

  6. Reboot the computer.

You should now be able to use the Vibe Edit in Place feature with Microsoft Office files.

NOTE:Although these steps enable Edit in Place for Vibe, they do not fix Vista’s inability to attach via WebDAV in Vibe.

For additional information on applets, view the following Sun bulletins:

7.24.4 WebDAV/Edit in Place Issue on Windows 7

If you use the Novell Vibe Edit in Place feature to edit a Word document using Office 2007 or Office 2010 on a Windows 7 workstation, Word requests a location to save the edited file rather than saving it back to the Vibe site. Depending on whether you want to run Vibe with a secure (HTTPS) or non-secure (HTTP) connection, this affects how you need to configure Vibe. For more information, see Editing Files with Edit-in-Place Functionality in Configuring Vibe to Support WebDAV on Windows 7 in the Novell Vibe 3.4 Administration Guide.

7.24.5 WebDAV URL Issue on Windows Vista and Windows 7

If you copy the WebDAV URL associated with a Novell Vibe folder and try to use the Add Network Location feature, Windows Vista and Windows 7 might not be able to map the drive. Instead, you should always use the Map Network Drive feature when using Vibe on Windows Vista and Windows 7.

7.24.6 WebDAV Limitations on Mac

When you use WebDAV functionality in a Mac environment, you encounter various limitations.

7.24.6.1 Limitations When Editing Files on Mac through WebDAV

Edit-in-Place functionality is not supported on Mac when you use Microsoft Office as your document editor. To use Edit-in-Place functionality on Mac, you must use OpenOffice or LibreOffice as your document editor.

For more information, see Using WebDAV to Edit Individual Files in the Novell Vibe 3.4 Advanced User Guide.

7.24.6.2 Limitations When Viewing a Vibe Folder on Mac through WebDAV

Because of limitations with WebDAV on Mac, you cannot use WebDAV to view a Vibe folder in a Mac environment.

For more information, see Using WebDAV on a Vibe Folder in the Novell Vibe 3.4 Advanced User Guide.

7.25 Viewing a Vibe Folder through Windows Explorer Displays an Additional Folder on Windows XP

On Windows XP, when you view a Vibe folder through Windows Explorer, an additional sub-folder with the same name as the parent folder might be displayed.

To resolve this problem:

  1. Launch a Web browser.

  2. Navigate to the Microsoft Download Center and install the Software Update for Web Folders (KB907306) http://www.microsoft.com/downloads/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en

  3. Follow the on-screen instructions to install the software update.

7.26 Data Quota Issue with OpenOffice.org

OpenOffice.org creates a new document version each time you click Save, instead of creating one new version when you exit the edited document. This behavior can cause you to quickly meet your data quota. You can avoid creating unnecessary versions of the same document, and if you do create them, you can delete them.

7.26.1 Avoiding Unnecessary Document Version Creation

To avoid creating unnecessary versions of the same document, do either of the following:

  • Do not click Save multiple times when editing a document. Instead, click Save only once, before closing the document in OpenOffice.org.

  • When you edit documents in Vibe, use a document editor other than OpenOffice.org, such as Microsoft Word.

7.26.2 Deleting Unnecessary Versions of a Document

You can delete specific versions of a file, as described in Deleting Existing Versions of a File in the Novell Vibe 3.4 User Guide.

7.27 HTML Conversion Error on a Linux Server

If you see an HTML Conversion Error when you try to view a file, your Vibe Linux server might be missing necessary libraries.

To install the missing libraries:

  1. Change to the following directory:

    /opt/novell/teaming/stellent-converter/linux/x86
    
  2. Run the exporter program.

    The errors about missing input and output files are to be expected.

  3. Look for errors about missing libraries.

  4. If there are library errors, install any libraries that are missing.

7.28 The User Profile Does Not Support Custom JSP Files

When you create or modify attributes for the User Profile form and view in the Form and View Designers tool, you cannot reference custom JSP files.

This ability still exists for modifying attributes for workspaces, folders, and entries, as described in Enabling Vibe Forms and Views to Reference JSP Files in the Novell Vibe 3.4 Advanced User Guide.

8.0 Database Issues

8.1 Microsoft SQL 2012 Is Not a Supported Database

Microsoft SQL 2012 is not a supported database for Vibe 3.4. Vibe 3.4 supports the same databases as were supported in Vibe 3.3. For more information about supported databases, see Vibe Server Requirements in the Novell Vibe 3.4 Installation Guide.

9.0 Developer Issues

9.1 Re-Compiled or Re-Built Vibe Code Is Not Supported

If you have re-compiled or re-built Vibe in a Development environment, your Vibe installation is not supported by Novell. Alternatively, please seek support for custom Vibe deployments in the Kablink Community or the Novell Vibe discussion forum.

This excludes JSP-based changes made to facilitate the development of custom Forms and Views.

9.2 Multi-Reference Values in SOAP Payloads

By default, Novell Vibe SOAP payloads do not generate multi-reference values. You can change the server-config.wsdd files so that multi-reference values are generated.

  1. Change to the directory where a server-config.wsdd file is located.

    A Vibe installation includes two server-config.wsdd files. The default locations of these files vary by platform:

    Linux:

    /opt/novell/teaming/apache-tomcat-version/webapps/ssf/WEB-INF
    /opt/novell/teaming/apache-tomcat-version/webapps/ssr/WEB-INF
    

    Windows:

    c:\Program Files\Novell\Teaming\apache-tomcat-version\webapps\
                                                       ssf\WEB-INF
    c:\Program Files\Novell\Teaming\apache-tomcat-version\webapps\
                                                       ssr\WEB-INF
    
  2. In the following line, change false to true:

    <parameter name="sendMultiRefs" value="false"/>
    
  3. Save the server-config.wsdd file, then exit the text editor.

  4. Create a backup copy of the modified server-config.wsdd file.

    If you update the Vibe software, the server-config.wsdd file is overwritten by the Vibe Installation program. You must either restore the updated file after the update or repeat the modification.

  5. Repeat the procedure for the second server-config.wsdd file in the Vibe software.

10.0 Localization Issues

10.1 Extended Characters Are Not Allowed in Simple URLs

On the Configure Default Settings page of your workspace, the Define URL field does not accept extended characters. Use only alphabetic characters and numbers in simple URLs.

10.2 Extended and Double-Byte Characters in Attachment Filenames

If Outlook users send postings to the Novell Vibe site and if the messages have attachments with extended or double-byte characters in the filenames, the attachment does not arrive on the Vibe site unless the Exchange server is properly configured. To configure the Exchange server to pass the filenames correctly, follow the instructions in Foreign Characters Appear as Question Marks When Sent from OWA.

10.3 Chinese Characters in Activity Logs

When a report.csv file for an activity report is opened in Microsoft Excel, Chinese characters do not display correctly, even though the report.csv file has been created correctly, because Excel always reads the file using the ISO Latin character set.

One workaround is to use the OpenOffice.org Calc spreadsheet program instead of Excel. It displays Chinese characters correctly.

As a workaround in Excel:

  1. Import the report.csv file into Excel by using Data > Import External Data > Import Data.

  2. Select the report.csv file, then click Open.

  3. Select Delimited, select UTF-8, then click Next.

  4. Select Comma as the delimiter, click Next, then click Finish.

Excel should now display the Chinese characters correctly.

10.4 Internet Explorer 6 Limitation with International Characters in Filenames

In Internet Explorer 6, if you upload a file whose filename includes international characters into a File folder, and if you edit that file and create a new version, the link to the original version of the file no longer works, because Internet Explorer 6 double-encoded the filename. To resolve this issue, update to Internet Explorer 7 or later.

11.0 Security Issues

To ensure that your Novell Vibe site is adequately secure, keep your operating system updated with all patches and security fixes.

12.0 Vibe 3.4 Bug Fixes

For a list of the bugs that have been fixed since Vibe 3.3, see the Novell Vibe 3.4 Bug List. For more information about each bug, you can look up the bug numbers in Bugzilla.

13.0 Vibe 3.3 Bug Fixes

For a list of the bugs that have been fixed since Vibe 3.2, see the Novell Vibe 3.3 Bug List. You can look up the bug numbers in Bugzilla for more information about each bug.

14.0 Vibe Documentation

The following sources provide information about Novell Vibe 3.4:

  • Online product documentation: Novell Vibe 3.4 Documentation Web site

  • Product documentation included within Novell Vibe. Click the Help icon (question mark) in the upper right corner of the Vibe Home page.

In addition to the Novell Vibe product documentation, the following resources provide additional information about Vibe 3.4: