Novell Home

Beans%2C Security Command

Security Command Beans (previously known as eCommerce Beans) provide easy-to-use Java* components to integrate Web applications with Java security. These components enable simple manipulation of security providers and certificates. Built with an MVC (Model-View-Controller) and Command architecture, Security Command Beans use open protocols, are written entirely in Java, and have no dependencies on native code.

The following Beans are in this category:

  • ListProviders
  • AddProvider
  • RemoveProvider
  • ListCertificates
  • RetrieveHostCertificates
  • ImportCertificate
  • DeleteCertificate

Downloads

Your use of these files is subject to the Novell Developer License Agreement unless different license terms accompany the file itself, in which case those terms govern.

novell-bns_seccmd-devel-2006.06.14-1cross_platform.exe

novell-bns_seccmd-devel-2006.06.14-1cross_platform.zip

novell-bns_seccmd-devel-2006.06.14-1cross_platform.tar.gz

novell-bns_seccmd-devel-2006.06.14-1cross_platform.i586.rpm

netware

novell-bns_seccmd-devel-2006.06.14-1netware.exe

novell-bns_seccmd-devel-2006.06.14-1netware.tar.gz

novell-bns_seccmd-devel-2006.06.14-1netware.zip

Download Archive

Documentation

Sample Code

What's New

June 2006

Updated the trademarks list as per Novell documentation standards.

Dependencies

Beans, Security Command

Security Command Beans requires

  • Java Runtime Environment (JRE) 1.1.7 or higher
  • JDK 1.2 Standard Edition or higher
  • The software installation requires a 32-bit operating system that supports Windows* 95 compatible long file names.

Support

This is an unsupported component. We strongly recommend that you do not select components from this page and begin to use them in a production environment.

© 2014 Novell